Page 1 of 1

Can't find camera drive.

Posted: 06 Apr 2015, 19:02
by EddyTheB

In a fit of stupidity I accidentally formatted my camera's memory card (I was trying to remember how to change the format of the images being captured, e.g. jpg to RAW). I've come across testdisk and photorec as a possible means to recover the photos that I thought I'd deleted. However I can't get photorec or testdisk to find my camera. When I run either from the terminal, and am asked to select the media, the only drive available is my laptop's internal hard drive.

Please could somebody explain how to get photorec (or testdisk) to recognize my camera when it is plugged in?

Thank you.


The camera is a Canon EOS 350D, connected by USB. I can access it's contents through the terminal by going to "/run/user/1000/gvfs/gphoto2:host=%5Busb%3A003%2C017%5D" (but only if I've first opened the camera's folder using nautilus, for some reason). I believe it's referenced as the final line when I run mount.

$ mount
/dev/sda2 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,nodev,noexec,nosuid)
... many more lines ...
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=eddy)

I'm running Ubuntu 15.04.

Re: Can't find camera drive.

Posted: 07 Apr 2015, 07:22
by cgrenier
Please put the memory card in an USB card reader instead of the camera and try again PhotoRec.

Re: Can't find camera drive.

Posted: 07 Apr 2015, 21:59
by EddyTheB
I'm not sure I can do that, it's not a normal sized SD card it's an enormous "Compact Flash" card and it won't fit in my laptop's card reader.

That said, I've found some inexpensive usb compact flash readers on amazon, so I'll order one of them and try that when it arrives.


Re: Can't find camera drive.

Posted: 09 Apr 2015, 17:43
by EddyTheB
The card reader arrived today, and it worked! Many thanks for the tip!