Page 1 of 1

PhotoRec stuck on a loop after reaching sector 1000000

Posted: 19 Nov 2016, 20:32
by Spirend
Now, i've heard that you can edit the photorec.ses-file, namely the sector offset, to fix this loop problem. But i'd like to be preemptive. I run a Windows machine, and recently had my Kingston _Datatraveller G3 give up the ghost in an odd manner. First, the PC stopped detecting it, claiming it was an invalid device or something along those lines. I could still see the drive name, but the gauge that shows how much room was left, was replaced with a text string detailing the filesystem type. FAT32, if it matters. Removing the device fixed this, but left the device write-protected, and crashed file explorer if i tried to copy files out of the device. Another removal destroyed the partition (i guess, i'm not an expert!) and rendered the device bricked. I ran PhotoRec last evening at...20:00-ish and let it trundle along until morning, when i noticed it was stuck on a loop arounds sector 1000000 of ~1200000, falling back to under a million sectors every time it was about to reach twenty thousand sectors above sector 1000000. I ended up just killing the process and running a virus scan which cut down a file with trappings to be a virus, but found no certifiable viruses.

I'll try running Photorec again, i've changed the first number of the sector offset from 1 to 2, but i'd like to know. In what way am i intended to edit the sector offset, and on the off chance this doesn't work, is there another way for me to break the loop?

Also, how can i make PhotoRec recover the full file structure, instead of packing the files into separate folders? It's a hassle sorting through them again...

Re: PhotoRec stuck on a loop after reaching sector 1000000

Posted: 20 Nov 2016, 09:11
by cgrenier
PhotoRec can not recover the original file structure. If you want to original file structure, use TestDisk, Advanced, List instead.
Use PhotoRec 7.1-WIP instead of older versions to reduce the number of jumps.
You can manually remove some sector ranges or alter one from photorec.ses but do not break the alignment: do not increment by one the start or end sector, add 16 or a multiple instead.

When a disk contains bad sectors, it's recommended to clone the disk to a new empty one using ddrescue from a Linux LiveUSB, see https://www.cgsecurity.org/testdisk.pdf for the details.
Once it's done, remove the old disk and use testdisk or photorec on the clone.