Page 1 of 1

SD Card read errors Controler?

Posted: 02 Jan 2017, 00:57
by tenspayn
My SD card was used in a Fuji XP90. All of the images disappeared - the camera went out of charge - not sure whether that was the problem. I closed the read lock on the card straight away
The card is recognized when I put it into the computer slot. It mounts and the DCIM and 100_FUJI folders show up and there are some icons showing up, but the file names are corrupted. Trying to copy them over to my hard disk gives me a splicing error.
photorec_static came up with no files to copy
I tried to look at the partition table using TestDisk but it didn't find a partition. A detailed analysis shows this:
Disk /dev/sdc - 15 GB / 14 Gib - CHS 14824 64 32 (RO)
Analyse cylinder 1862/14823: 12%
Read error at 1862/1/1 (lba =NNNNNNN)

etc. etc. So each cylinder is failing to be read by the looks of it.

Its a 16GB SD Card, not sure if the 15GB given is therfore important

I tried to use TestDisk to make an image.dd. It wrote a file with the message "there were errors" but using photorec on the image it produces an ioctl error - file unreadable.

Help or observations gratefully accepted. The card is from my 11 year old daughters camera and has/had every cake she's baked for three months - and bad Dad didn't think to back up a brand new card in a brand new computer.

Thanks Simon

Re: SD Card read errors Controler?

Posted: 02 Jan 2017, 07:40
by cgrenier
Try latest PhotoRec 7.1-WIP on this card. Choose [Whole] instead of [Free] after selecting the partition.

Re: SD Card read errors Controler?

Posted: 02 Jan 2017, 21:34
by tenspayn
Thank you for your help

I had a problem finding the whole/free option so I had to leave that. The option doesn't appear to show up. I'd appreciate some help there.

Pass 0 gives 0/10 headers and no files are copied on pass 1