0% after 2 weeks

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 2
Joined: 22 Feb 2017, 23:06

0% after 2 weeks

#1 Post by thompsk »

using 7.1 WIP

I have a 2tb mac drive that was reformatted after a bad sector. So I dd it to a win PC file

I tried DIskDoctor(trial) and it found every file in an hour or so. I test extracted a couple and they were perfect.

So I set photorec-win going on it and it started finding files (yeah!!!!)- sadly the front of the disk looks like cache folders and after 2 weeks its up to directory 140, but I note the following.

The disk is being read continuously @80M/s - about right for the drive (so its already read a couple of petabytes already - or more)
60M System and 20M photorec.exe - does it really need to continuously read like this over and over again - there is nothing wrong with the disk - and I even defragged it before starting sp at least the dd file was contig..

It is still at 0% - so looks like the universe may expire before the files are recovered. :(

I get the impression it tries to extract a file and writes it to disk, then changes its mind and deletes it. Almost as if it goes byte by byte and for each byte try to write out a file, see if the file is OK, if so SAVE else, try another type, with thousands of types and zillions of bytes - maybe thats why its at 0%

Ive tried cutting down the file types to just photo - but that didnt make much of a difference, and I was thinking, maybe after a while it will just speed up - but NO.

What am I doing wrong ?

Surely if DiskDOctor can find the files, photorec shouldnt be that far behind ??

Sponsored links

User avatar
Site Admin
Posts: 5327
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: 0% after 2 weeks

#2 Post by cgrenier »

Do you have the same problem with latest 7.1-WIP ?
If asked, be carefull to choose [whole] instead of [Free] after selecting the partition.

Posts: 2
Joined: 22 Feb 2017, 23:06

Re: 0% after 2 weeks

#3 Post by thompsk »

I have a version downloaded 25 jan 2017 of 7.1WIP (assuming that the WIP is a moving target.

I see from you git commit comments that this IS the current (last compiled author Christophe Grenier <grenier@cgsecurity.org> 2016-12-26 19:20:30 (GMT) )

7.1-WIP Sun Jan 22 09:45:54 CET 2017