No harddisk found

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Post Reply
Posts: 2
Joined: 28 Feb 2018, 09:45

No harddisk found

#1 Post by alafortanfuni » 28 Feb 2018, 09:55

Hello, I want to recover a folder I deleted from my internal harddisk. I have two partitions on my harddisk. The folder I deleted was on the secondary partition. When I run photorec app, terminal window opens and asks me my password. Then it says no hardisk found. If I connect an external drive, photorec sees it. However the folder I want to recover is on my internal harddsik. How can I force photorec see the internal drive?

My System: imac late 2009, macos high sierra v 10.13.3, 2 TB harddisk with two partitions, 1 TB main and 1 TB secondary.
Screen Shot 2018-02-28 at 11.43.26.png
Screen Shot 2018-02-28 at 11.43.26.png (36.03 KiB) Viewed 5103 times

Sponsored links

Posts: 2
Joined: 28 Feb 2018, 09:45

Re: No harddisk found

#2 Post by alafortanfuni » 01 Mar 2018, 22:05

I found the solution. Issue is related to version high sierra (v 10.13). Now I can see the internal harddisk. Tried to rescue some files and it worked.
I copy-paste the solution here, in case someone may have been suffering the same problem.

Note: Recover Lost Mac Data under Mac OS X 10.13 (High Sierra)
Due to macOS High Sierra (macOS 10.13) requirement, Mac users are not allowed an access to the built-in system drive from any apps. Therefore, if you need to restore lost data from the system disk under macOS 10.13, please "disable System Integrity Protection" first.

How to disable "disable System Integrity Protection"? Please follow the steps below.

Step 1: Reboot the Mac and hold down"Command + R" keys simultaneously after you hear the startup chime, this will boot OS X into Recovery Mode.

Step 2: When the "OS X Utilities" screen appears, pull down the "Utilities" menu at the top of the screen instead, and choose "Terminal".

Step 3: In the "Terminal" window, type in "csrutil disable" and press "Enter" then restrart your Mac.

Posts: 2
Joined: 05 Mar 2018, 09:59

Re: No harddisk found

#3 Post by richardd » 05 Mar 2018, 10:28


I'm desperately trying to recover some deleted files (.JPG) and run in to the same problem with my OS Linux Cinnamon.
Screenshot from 2018-03-05 09-42-49.png
Screenshot from 2018-03-05 09-42-49.png (19.47 KiB) Viewed 5067 times

User avatar
Site Admin
Posts: 4752
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: No harddisk found

#4 Post by cgrenier » 06 Mar 2018, 09:06

As explained in , run

Code: Select all

sudo photorec
As root, you should see all your disks.

Posts: 2
Joined: 05 Mar 2018, 09:59

Re: No harddisk found

#5 Post by richardd » 07 Mar 2018, 09:27

I tried the sudo photorec but it gave the same result.
Maybe a different suggestion?

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests