configure file missing in archive Topic is solved

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 27 May 2018, 08:27

configure file missing in archive

#1 Post by mbiwer » 27 May 2018, 10:34


I am trying to install testdisk/photorec according to
  • running Xubuntu 18.04 LTS
  • installed the compilation environment
    apt-get install -y build-essential ...... dh-autoreconf git
  • extracted with tar xjf ...
There is no file "configure" in the resulting directory testdisk-7.1-WIP.

Tried the same with the 32-bit-archive ( and the git repository (git clone Same result - no configure file. Where am I wrong???

Thanks in advance for any help! ... 26.tar.bz2

Sponsored links

User avatar
Site Admin
Posts: 4642
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: configure file missing in archive  Topic is solved

#2 Post by cgrenier » 31 May 2018, 06:08

You have downloaded 32-bits and 64-bits binary packages, so no configure script is present. You can use the photorec_static or testdisk_static binaries directly.

When using git to get the source code, you have to create the configure script as state in the documentation by using autoreconf:

Code: Select all

cd testdisk
mkdir config
autoreconf --install -W all -I config

Posts: 2
Joined: 27 May 2018, 08:27

Re: configure file missing in archive

#3 Post by mbiwer » 02 Jun 2018, 09:43

Christophe, merci beaucoup! Works great now.


Who is online

Users browsing this forum: No registered users and 1 guest