Research encrypted APFS (macOS) data/file recovery Topic is solved

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Post Reply
Posts: 2
Joined: 31 Jan 2019, 10:03

Research encrypted APFS (macOS) data/file recovery

#1 Post by ldexterldesign » 31 Jan 2019, 10:20

Hi all,

Thanks for software

Hope you're well

Unfortunately, I deleted some files today:

find /foo "*.nfo*" -delete

... which not only deleted my .nfo files but everything inside and including foo (I still need to find out why it did that)

I'm hoping to use photorec to recover these files but when I load the cli I get the following:

No harddisk found
You need to be root to use PhotoRec.

I tried:

sudo photorec

... but same issue

What am I doing wrong?

FYI My file system is encrypted APFS (macOS)

If you have any issues (e.g. questions/queries) then happy to help

Hope to hear back

Yours faithfully

Sponsored links

User avatar
Site Admin
Posts: 4720
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Research encrypted APFS (macOS) data/file recovery  Topic is solved

#2 Post by cgrenier » 02 Feb 2019, 20:54

Currently PhotoRec can't recover deleted files from encrypted APFS.
But some commercial data utilities claims to be able to recover deleted files from encrypted APFS as long as you have the password.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests