EFI GPT Partition

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 14 Jul 2019, 19:50

EFI GPT Partition

#1 Post by tbone5803 »

Trying to recover a failed external Seagate hard drive. It worked temporarily in TestDisk but now no file structure is present at all. It also says it has a an EFI GPT partition. Not sure how to safely change this to NTFS. I found the following partitions on the drive:

1. P EFI System No HFS or HFS+ structure
2. P Mac HFS
2. P Mac HFS

When I look for a partition in analyze it says
check_FAT: Unusual media descriptor (0xf0!=0xf8)
Warning: number of heads/cylinders mismatches 16 (FAT) != 255 (HDD)
Warning number of se7tors per track mismatches 32 (FAT) ! = 63 (HD)

Not sure what to do at all. I think the hard drive is not syncing because the partition is incorrect somehow. I only had one main partition on this external. I believe it should be NTFS as I'm using a Windows PC machine.

Sponsored links

User avatar
Site Admin
Posts: 5289
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: EFI GPT Partition

#2 Post by cgrenier »

It looks like a disk from a macOS computer!
Try TestDisk, Analyze, Quick Search and Deeper Search if no NTFS partition is found during Quick Search.
If the NTFS partition is found, set it to P(rimary). On next screen, choose Write, confirm, Quit and restart your computer
If it doesn't work, try PhotoRec to recover your data.
Good luck