Does Photorec modify in any way the SD Card? (+ Story)

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
kis3lori
Posts: 1
Joined: 05 Aug 2019, 14:32

Does Photorec modify in any way the SD Card? (+ Story)

#1 Post by kis3lori » 05 Aug 2019, 14:43

Hello,

I have an issues and I really have no idea what went wrong. It's a bit of a long story so I'll summarize it in case you don't want to read it.
TL;DR: I used photorec on a SD Card to recover some deleted photos and now the phone says the SD Card is corrupted... Does photorec change anything in the SD Card that might corrupt it or did I do something else?

Long Story:
My dad had a phone that had full internal storage. No matter what I did the storage did not go down... (removed apps, cleared cache, moved all photos to SD Card, etc.)
So I decided to do a factory reset and before that I checked again that ALL photos are on the SD Card. The I did the reset.
During the Factory Reset somehow all the photos on the SD Card were deleted. So I decided to try to recover them.
I used photorec (I'm on linux) to recover all the images from the SD Card, and it sort of worked. It seems I recovered some of them but I don't think all of them...
Anyway, I re-inserted the sd card into the phone and now the phone says the SD Card is corrupt card I need to format it...

Is there anyway I can fix this mess? Does anyone have any idea what went wrong in the first place?

Thank you,
Lorand

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4846
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Does Photorec modify in any way the SD Card? (+ Story)

#2 Post by cgrenier » 07 Aug 2019, 10:06

PhotoRec opens the source device in read-only, so it can not modify the source.
If some pictures are missing, keep the files already recovered (better to be safe), run again PhotoRec, enable the expoert mode in Options, start the recovery, when asked, choose a blocksize of 512 bytes, use the default options otherwise.

Maybe your Linux has mounted the source disk while you were using PhotoRec and you didn't eject (umount) the SD card properly.
You should be able to format the SD card again.

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests