Recovery of Macrium reflect .mrimg

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Post Reply
Posts: 2
Joined: 25 Aug 2019, 13:02

Recovery of Macrium reflect .mrimg

#1 Post by caston » 25 Aug 2019, 13:11


When rebuilding my workstation I accidentally formatted an NTFS partition with macrium two reflect images. I had a working backup for the smaller one but there is a larger one over 400gb for which my backup is corrupted. I am trying to recover the .mrimg file with photorec but it does not support the filetype. I have found some instructions ( ... o_PhotoRec) and here ( ... file-type/) but this is a bit confusing for me and the guide is using much simpler files such as a .php file.

Would it also be possible to add support for the Macrium reflect image file?

I created a test one of a very tiny FAT32 partition and tried on the photorec online checker and it said: ERROR: PhotoRec doesn't know this format. ... ef83d73b0c

Would anyone be able to tell me if what I am doing is possible and be able to help me through the process. It would be very much appreciated.

I am working on Windows 10 and I have the Linux subsystem with Ubuntu installed. I also have a Ubuntu machine I can work from if needed.

Sponsored links

User avatar
Site Admin
Posts: 4994
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Recovery of Macrium reflect .mrimg

#2 Post by cgrenier » 25 Aug 2019, 16:48

The small image file you provide looks like a truncated raw image.
I have successfully opened it using TestDisk, Geometry, Cylinders=10 (arbitrary large enough value), Boot, List.
The probability that your 400gb lost file was unfragmented is near 0, so PhotoRec will not work.
As yo are using Ubuntu, you can try the scrounge-ntfs utility. You need to have enough free space on another disk to store the recovered files.

Posts: 2
Joined: 25 Aug 2019, 13:02

Re: Recovery of Macrium reflect .mrimg

#3 Post by caston » 26 Aug 2019, 09:35

thanks cgrenier,

I put the drive in my Linux machine and have had some success with with scrounge-ntfs. It has found the .mrimg file OK but seems to be stuck only 3.6gb in. (3,624,064,138 bytes) and not changing. Took dog for walk and still the same. This is with the -c option set to the default of 8. I tried with 4 but it gets stuck a few kb in. (681,984 bytes)
I am recovering it to an external usb HD.

To be more precise it wasn't a reformatted partition. I deleted it by accident when reinstalling Windows 10 so it's a blank space that I am working from.

Post Reply