1 TB ssd drive used as local c drive invalid handle

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Locked
Message
Author
tbmcisp
Posts: 1
Joined: 13 Oct 2019, 15:17

1 TB ssd drive used as local c drive invalid handle

#1 Post by tbmcisp »

I have a 1tb ssd drive that i used as my local c drive.it failed.I put it in a usb enclosure.
when i plug it in I see the drive as system E it says failed to scan ,the handle is invalid.
when I run photorec it doesn't see any drives till i unplug this one.
I only want to get my video files how should I proceed ,should i try a quick format?
Terry McNamara 617-592-0438

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 5315
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: 1 TB ssd drive used as local c drive invalid handle

#2 Post by cgrenier »

If possible,
- avoid using an USB enclosure.
- try to clone the disk using ddrescue to a new empty disk, see https://www.cgsecurity.org/testdisk.pdf for details
Once it's done, remove the original disk and try to recover your data from the clone.
If it failed, you should contact a data recovery company.
Good luck

Locked