Disconnected during file copy

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 03 Aug 2014, 21:57

Disconnected during file copy

#1 Post by moonbirdblue »


My pc hasn't registered my external drive for several months, saying it needs to be formatted before use. I found TestdDisk & was so excited to see that it recovered many of my files! Unfortunately I believe the hard drive was disconnected (maybe the cable got knocked) while the files were being copied to another external drive. So now whenever I go through the whole process & try to copy the rest of the files, it always says "Copy done! 0 OK, X Failed", x being however many files I try at that time. I've even done the Deeper Search with the same results.

Today I tried writing the partition (not even sure what that means), rebooted & nothing is different. I can still see all my files on the drive through TestDisk but I'm wondering if there's any way to get them back? It's mostly photos.

Thanks so much for any help!

User avatar
Site Admin
Posts: 5432
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Disconnected during file copy

#2 Post by cgrenier »

Try to clone your disk to a new empty one and use testdisk to copy the files from the clone.
There may be bad sectors on your disk.