Drive stopped working after linking to Kodi

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 15 Oct 2015, 22:34

Drive stopped working after linking to Kodi

#1 Post by Kevin »

I have a 1.5tb hard drive that i switched from a dumb media player(no internet access, just played files based off the file-name) to kodi box. As i was checking the files in kodi, i noticed some videos were not loading. Then i tried in windows explorer and the drive wouldnt open at all.

When i try to open it, i get this:

I run testdisk:
1.create log the right DISK(not just the drive)
3.chose the default partition table type(intel/pc)
4.analyse it > quick search
5.I get this window
6.I keep it as a primary bootable drive(*)
7.I select "write" on the next screen.
8."Write partition table, confirm?(y/n)" i select Y
9.I am instantly told i need to reboot for changes to take effect.

After rebooting, i get windows prompting me to scan the disk for errors,(i agree). i try to open it up again through explorer and get the same error message as before though.

Anyone have any ideas? The files are all still on the drive, if i look at the "list" option through testdisk. I even recovered a few. It took a few minutes for a 700mb file, but it was all there and played fine. Trying to recover the ENTIRE 1.4tb would be painful, as i dont have another large drive to act as the middle-drive, as i migrate it over and then reformat the original drive and relocate them back to it.

User avatar
Posts: 2835
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Drive stopped working after linking to Kodi

#2 Post by Fiona »

Looks like that you've already a partition in your partition table.
Writing it another time would not help.
I assume that your partition is available, but appears as RAW.
Raw indicates often a problem with the boot sector and file system.
So there would be no reason to do something with your partition table anymore.
Can you run Testdisk / Advanced, your partition must be selcted and confirm at Boot?
Can you upload another snapshot?
Until yet, it's not recommended to write anything and don't use RepairMFT, because it can modify your file system and should only be used in conjunction with chkdsk.
In your testdisk folder you'll find a file called testdisk.log.
Can you open it using wordpad and copy and paste the content into your next post?
Can provide more info about the condition of your file system.