Filesystem damaged/Undelete Micro SD Card GoPro Videos

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 22 Sep 2016, 18:28

Filesystem damaged/Undelete Micro SD Card GoPro Videos

#1 Post by chriscombs »

Hi all,

Ive searched high and low for possible solutions with test disk with no luck.

I have a San Disk Ultra 64gb microSD card plugged into the appropriate adapter going straight into my mac. On it are videos Im trying to retrieve that were deleted by the GoPro importer app because of the "automatically delete after import" option. They were deleted after a failed import due to multiple GoPro cameras having same name.

No other data has been written on the card since, so there should be nothing that has overwritten them yet.

I have tried PhotoRec. It is able to find and restore damaged versions of the videos, which I was able to try and repair, however that will not suffice for the video I am trying to make - 360 video requiring 6 videos of the same FPS etc...

I have tried
- Undelete - only shows the folder the files were in. When trying to open that folder, I get "No file found, filesystem may be damaged"
- Geometry fix - I was getting the error saying "head is showing 1 but it may be 128"
- Making a clone of the disk and using testdisk on the clone image and trying to change values further with no luck
- Analyzing - I get a "Warning: Bad ending head (CHS and LBA dont match)

Disk /dev/disk3 - 63 GB / 59 GiB - 124735488 sectors (RO)
Current partition structure:
Partition Start End Size in sectors

1 * HPFS - NTFS 32768 124735487 124702720

Warning: Bad ending head (CHS and LBA don't match)

After quick search:

Disk /dev/disk3 - 63 GB / 59 GiB - 124735488 sectors (RO)
Partition Start End Size in sectors
>* HPFS - NTFS 32768 124735487 124702720

Structure: Ok. Use Up/Down Arrow keys to select partition.
Use Left/Right Arrow keys to CHANGE partition characteristics:
*=Primary bootable P=Primary L=Logical E=Extended D=Deleted
Keys A: add partition, L: load backup, T: change type, P: list files,
Enter: to continue
exFAT, blocksize=131072, 63 GB / 59 GiB

Based on all of the searching Ive done, I cannot seem to find any other options to what should be a very easy fix. The same problem happened again to a different card and I was able to Undelete those files instantly using testdisk.

A couple questions I had:
Should I be writing a partition table to the card after it did a deep search? Test disk says Write access for this media is not available.

My card is also easily recognizable by my mac, so the card seems to be working fine. The issue seems to be in finding the lost partition or filesystem with my files on it.

Any help would be greatly appreciated!


Sponsored links

User avatar
Site Admin
Posts: 5310
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Filesystem damaged/Undelete Micro SD Card GoPro Videos

#2 Post by cgrenier »

Can you provide a disk image of the memory card ? Run TestDisk Advanced, Image Creation. Once done, compress (ie. zip) the image.dd file and share it via Google Drive or similar service.