Can't delete files recovered with TestDisk

Using TestDisk to undelete files
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 25 Feb 2019, 03:29

Can't delete files recovered with TestDisk

#1 Post by bp2017 »

Hello, everyone!

I extracted TestDisk (7.0 for Windows) from compressed archive and created "DESTINATION" folder inside it. Then I ran TestDisk to recover thousands of text files into that folder. I managed to delete almost all of the recovered files when I no longer needed them, but the folder itself together with a few files inside can't be deleted for some reason.

When I'm trying to delete the folder using Windows Explorer, I get "Could not find this item. This is no longer located in \testdisk-7.0. Verify the item's location and try again." And same goes for the two files inside.

Does anyone know what could cause this and how I can get rid of that folder? Would it even be properly erased when I reformat the disk (although I'm not planning on doing so in the near future)?

Your help is appreciated. Thank you.

Sponsored links

User avatar
Site Admin
Posts: 5289
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Can't delete files recovered with TestDisk

#2 Post by cgrenier »

You may need to take ownership of the folders.

Posts: 2
Joined: 25 Feb 2019, 03:29

Re: Can't delete files recovered with TestDisk

#3 Post by bp2017 »

cgrenier, thank you for replying.

The folder has been in ownership of a user-group to which I belong. I opened properties of the folder and checked just in case and I have full control (permission to delete) of the folder, I even changed the ownership from the group to myself but the issue remains.

Although I discovered that files which can't be deleted inside the folder have an error displayed on the Security pane ("The requested security information is either unavailable or can't be displayed.") so I couldn't make sure I have control over them.

I mentioned recovering text files but by the name of those that can't be deleted I recognize them as media files (one is mp3 and another is mp4, but they have no extension and are corrupted--however, retained their size: ~10 MB and ~117 MB). I must've recovered more file types than I thought (since it was weeks ago, I forgot what exact file types I tried to recover with TestDisk). Now that I think of it, I remember trying PhotoRec but can't recall the details. If it helps, I'm sure I needed to recover an html file and had hundreds of thousands recovered files in the folder I can't delete now.

The issue of 2 files that can't be deleted doesn't bother me much. I just hope that the disk reformats correctly when the time comes, and thought it would be helpful to provide you with feedback to try avoid similar issues in the future.