Accidental Double Format Memory Card (Canon Camera with Magic Lantern Firmware)

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
Icaab
Posts: 1
Joined: 04 Aug 2022, 21:32

Accidental Double Format Memory Card (Canon Camera with Magic Lantern Firmware)

#1 Post by Icaab »

Hello
I apologize if I wrote in the wrong section.
I read similar topics, but I have no idea what to do in my case.
By accident I mixed up my memory card (sandisk extreme pro 128gb) and formatted first on the camera (low-level, which is available in the cameras canon) ,and then on the computer.
It is then recognized by the computer in the exFAT file system.
After starting to recover the card via R-studio and Recuva. At some point the card completely ceased to display. The second program created the disk image before it was recovered and after it was finished, the memory card was displayed in the explorer again. She changed her icon. It used to be like hdd, and then it became different.
https://ibb.co/S63snxs
I don’t remember this happening before after the computer formatted. Maybe the filesystem was before NTFS, but it’s unlikely.
Back to the point: The data did not recover. I think the additional complexity was that the memory card was firmware Magic Lantern, which saves video in the format .MLV

Began to stumble on similar topics related to the recovery of mlv files. Recommended photorec and testdisk. And...maybe I didn’t quite figure it out, but I decided not to take any chances with some of the features.

PhotoRec
In the first, I chose to find all files, paranoid mode, no partition and [Other] file system.
Finds nothing (changed some parameters, for example, suggested choosing the NTFS filesystem (whole), and the same)

TestDisk
Intel > Analyze > Quick Search
Displays NTFS. When viewing files - Can’t open file system. Filesystem seems damaged
Choose deep search. Same.
I chose the type of file system exFAT I can not.
Intel > Advanced
Not in List, not in Undelete there are no files
In Boot writes the following
https://ibb.co/hMHR2W4
I’m not quite sure what to do
Came back and chose another partition table
None > Type
Selected exFAT. Logged in boot
https://ibb.co/XS0N7h3
In List and Undelete
https://ibb.co/LrSNy5F
Left Advanced, logged into Analyse and included Deep Search. The next day after scanning came to see the files, but there were none.
Decided to stop so as not to make mistakes.

In Linux photorec led in the same way as in Windows. Testdisk too. I did not waste time there.

For the experiment I took another memory card (Sandisk extreme pro 32gb) with unnecessary information. Formatted it in exFat and tried to recover it in photorec. The result was received in a minute.
Formatted after in NTFS - the program also found files.
Formatted in the camera - files slower, but were.
After did low-level formatting. The card became recognizable in the computer in FAT32 format(was exFAT). Did the same operation in Photorec and the data began to be slowly read and no files. I think I repeated the same situation as my last memory card.

I think I have the following options to choose from:
1) Make the memory card image . dd and use the Write function
2) Format the memory card in another file system
3) We advised in one topic on this forum - to write one clip on a memory card and then try with it to recover past files
(this theme viewtopic.php?p=21042&hilit=MLV&sid79ab ... 741#p21042 )
4) Make in testdisk rebuild some file system

I wanted to do some of this, but the forum advised to appeal here in support.

recuperation
Posts: 2117
Joined: 04 Jan 2019, 09:48
Location: Hannover, Deutschland (Germany, Allemagne)

Re: Accidental Double Format Memory Card (Canon Camera with Magic Lantern Firmware)

#2 Post by recuperation »

Please consult a professional recovery service.

Post Reply