2 disks showing RAW that used to be in RAID1

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
ejackson
Posts: 1
Joined: 20 Sep 2022, 15:23

2 disks showing RAW that used to be in RAID1

#1 Post by ejackson »

Ok I am hoping I can recover these files. I have 2 x 8TB disks that were in raid1 mirrored (ReFS). I was setting up a new machine and plugged these disks among others into the mobo and began getting a GPT header corruption message (asus mobo). I was able to boot to the OS disk fine and everything seemed to be working. I saw the files on the 8tb drives at this time. I researched the error after rebooting several times and getting annoyed. people said they set the bios to auto recover if that happens. Well turns out the message was about my 8TB drives. Now both are showing RAW and want me to format to use them. I never formatted anything, I feel like the files are still there. I tried using Testdisk to recover the partitions but I fear maybe I am not using it correctly. It autodetected EFI GPT so i scanned both drives with this option. It took 5 days to scan and the first one just finished. It located 4 partitions but I did not get a screenshot before i started looking into those partitions. Once i went into the first one i could not figure out how to get back out and eventually ended up back at the analyze option i started with and it started to scan all over again. For that drive, I ended up rescanning as intel/pc the 2nd time. I still have the other drive finishing up soon at 95%. I am hoping to get some information on how i can navigate this one correctly so I do not waste more time.

UPDATE:attached the screenshot of the partitions found after the 2nd scan. it was the same as the first scan i exited.
Screenshot 2022-09-20 154043.png
Screenshot 2022-09-20 154043.png (135.38 KiB) Viewed 513 times

recuperation
Posts: 2176
Joined: 04 Jan 2019, 09:48
Location: Hannover, Deutschland (Germany, Allemagne)

Re: 2 disks showing RAW that used to be in RAID1

#2 Post by recuperation »

Go to the main page www.cgsecurity.org and click on "Testdisk".

This page provides you with the necessary information to judge if your case can be handled by Testdisk. The proprietary ReFS is not listed there.
Furthermore you only see linux RAID configurations.

As you did not provide any information about what is providing the RAID functions I can only guess that you are using some hardware RAID solution.

I am not aware of any common standard that describes RAID structures on disks.
That means that connecting your disks to another RAID controller is already dangerous. You should have copied the content to your new machine instead.
There is no guarantee that the new machine understands the content of your disks.

Post Reply