Partition still not recognized after repair

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 6
Joined: 09 Mar 2023, 05:28

Re: Partition still not recognized after repair

#11 Post by Rushkie »

recuperation wrote: 10 Mar 2023, 18:28 So nothing changed after writing the partition table?
Not that I can tell, except that I actually realized since originally posting that the partition I have screenshotted that is marked drive letter E: in disk management is actually only showing up/being created after I run testdisk. I originally thought it was always there after I restart, but if I delete it and restart and don't run testdisk yet it shows the entire disk unallocated. Once I use testdisk and try to repair the GPT partition and restart then that 2048GB RAW partition seen below appears, which obviously is incorrect still.
Untitled.png (6.04 KiB) Viewed 549 times

Posts: 2363
Joined: 04 Jan 2019, 09:48
Location: Hannover, Deutschland (Germany, Allemagne)

Re: Partition still not recognized after repair

#12 Post by recuperation »

Don't forget to disconnect and reconnect that drive. Otherwise windows won't be aware of the changes.

User avatar
Site Admin
Posts: 5406
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: Partition still not recognized after repair

#13 Post by cgrenier »

Your screenshot shows "Disk 4 Basic" but TestDisk has rewritten the partition table as EFI GPT.
If properly ejecting the disk/reconnecting it Windows still display the disk as Basic, check if an antivirus doesn't prevent TestDisk writing the new partition table.

Post Reply