Keine Undelete Option

Mit TestDisk gelöschte Dateien wiederherstellen
Forum rules
Your help is welcome: there are currently few answers or none to most message posted in the German forum!
If you want to post a request for help, please consider using the English forum.
Locked
Message
Author
jalt
Posts: 2
Joined: 07 Dec 2023, 15:51

Keine Undelete Option

#1 Post by jalt »

Moin zusammen,

Habe folgendes Problem:

SSD, funktioniert problemlos, es wurden ein paar Daten gelöscht die ich gerne wiederherstellen würde. SSD war Bitlocker-verschlüsselt, Verschlüsselung wurde deaktiviert. Benutze TestDisk unter Windows direkt.

Ich wähle beim Start die Platte aus, komme in die korrekte Übersicht für die Partitionen über Advanced. Sehe die Partitionen auch korrekt (Windopws Recovery, EFI System, MS Reserved, MS Data).
Aber egal welche Partition ich wähle, ich habe nur die Optionen Type, Image Creation und Quit.
Wähle ich bei der MS Data Partition über Type "NTFS", erhalte ich die fehlenden Optionen, bei Auswahl von Undelete aber den Fehler "Can't open file system. Filesystem seems damaged"

Vielleicht kann mir noch jemand einen Tipp geben was ich falsch mache. Gleichen Fehler habe ich übrigens bei einer Live-Distri mit TestDisk unter Linux.

recuperation
Posts: 2762
Joined: 04 Jan 2019, 09:48
Location: Hannover, Deutschland (Germany, Allemagne)

Re: Keine Undelete Option

#2 Post by recuperation »

Die gelöschten Daten wurden dank TRIM-Befehl des Betriebssystems an die SSD vermutlich schon vernichtet.

"Sehe die Partition korrekt" ist nicht ausreichend. Man muss mit Testdisk hereingucken können ("p"-taste, "list files").

Mal eben so "Bitlocker deaktivieren" geht nicht.
Testdisk sieht vermutlich nur verschlüsselte Daten.

Da müsste man die betroffene Festplatte bzw die Partition erst einmal entschlüsseln und dann kann man noch einmal probieren.

jalt
Posts: 2
Joined: 07 Dec 2023, 15:51

Re: Keine Undelete Option

#3 Post by jalt »

An TRIM hatte ich nicht gedacht.
Bitlocker deaktivieren beinhaltet das Entschlüsseln der Daten. Wurde auch geprüft, schau ich aber nochmal.

Danke schonmal für die Antwort :-)

Locked