Photorec infamous loop

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Post Reply
Posts: 1
Joined: 09 May 2024, 12:03

Photorec infamous loop

#1 Post by Flaubert »

I'm trying to recover data from a 4Tb external disk (did a "dd" command by mistake, erasing NTFS/FAT32 structure). Tried to recover file structure with Testdisk, but no luck.
Then I'm trying to recover files with Photorec v7.2WIP (windows) and, while it reached 9% disk very fast, it is now stuck in a loop from sectors between 744257389 and 773748756. It seems that, when it finds a file (usually an useless dll) it starts again from 744257389.

My session file is (at some moment) as this
\\.\PhysicalDrive3 partition_gpt,2,blocksize,512,fileopt,everything,disable,custom,enable,7z,enable,bz2,enable,class,enable,doc,enable,dvi,enable,exe,enable,gif,enable,gz,enable,iso,enable,jks,enable,jpg,enable,mov,enable,mp3,enable,mpg,enable,mpl,enable,mrw,enable,ogg,enable,pdf,enable,ps,enable,psd,enable,rar,enable,txt,enable,xm,enable,zip,enable,options,paranoid,keep_corrupted_file_no,wholespace,search,status=ext2_off,748014705,inter


It seems that value in last line (773748756) is like a limit for searching as it loop backs when reaches it, but I don't know why. Also, first number in .ses file(#1715251660) advances in time, but last number in "partitio_gpt..." line (748014705 in example) changes going back and forth, always in the range that it is "loopping" (74425738 - 773748756) . Is this behavior normal? What should I do in order the recovery advances from the 9% to other sectors?
is it possible to avoid "dll" files detection which seems part of the problem?
thanks in advance!!

Posts: 2794
Joined: 04 Jan 2019, 09:48
Location: Hannover, Deutschland (Germany, Allemagne)

Re: Photorec infamous loop

#2 Post by recuperation »

Please use the most recent version on top of the download page:

Currently, this is version 7.2 - not 7.2-WIP!

Please report if the bug occurs again.

Post Reply