nef files recovered then truncated

Using PhotoRec to recover lost data
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 2
Joined: 22 Apr 2013, 14:21

nef files recovered then truncated

#1 Post by reod »

Firstly thank you for photorec, it has helped me get some files off a disc that Windows won't even see.
I am using photrec 6.14 in parted magic.
I have recovered orf and jpeg files and am now trying to recover nef files.
If I leave multiple file types selected I do not get any nef files.
If I select only tif then I do get nef files (about 1000 of them) but the files are only about 1MB (exact size varies). If I check what is happening by listing the recover directory while photorec is running then I see the size of the recovered file growing to 20MB or more as expected but then it gets truncated to about 1MB.
Is there anything I can do about this - I have left the "paranoid" and other options at the default as I don't really understand them!

Thanks in advance for any help you can give on this.

User avatar
Site Admin
Posts: 5432
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: nef files recovered then truncated

#2 Post by cgrenier »

Can you download the 6.14-WIP version from my website and check if you have the same problem ?

Code: Select all

wget -N
tar xjf testdisk-6.14-WIP.linux26.tar.bz2
cd testdisk-6.14-WIP
sudo ./photorec_static

Posts: 2
Joined: 22 Apr 2013, 14:21

Re: nef files recovered then truncated

#3 Post by reod »

Thanks for your reply.
At the weekend I played with the settings and tried Paranoid:No and Keep Corrupted Files:Yes.
This gave me full size files (including some larger than I would expect). I've not yet been able to thoroughly check them all but they show as thumbnails in Lightroom. And a test one loaded ok into Lightroom.
So it may be that this has resolved my problem - further checks will tell.

I have 6.14-WIP in Parted Magic. But if I find the problem has not been resolved I will try the version from your website.