my 1TB USB disk says dynamic invalid, but nothing when mounted

Using TestDisk to undelete files
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
gordon55gg
Posts: 1
Joined: 06 May 2020, 03:53

my 1TB USB disk says dynamic invalid, but nothing when mounted

#1 Post by gordon55gg »

Hi,
Somehow I managed to brick my 1TB HDD.
I would like to get advice on how to recover all files.
Normally I mount it as a USB drive using a USB adapter.
It can also be mounted internally (sata).
1) File explorer shows nothing.
2) Mounting it internally shows nothing in disk manager.
Although bios on boot up shows the disk name.
And device manager shows the disk's name.
Maybe I should try uninstalling that disk's driver?
3) Mounting with the USB adapter shows no disk filename on boot.
disk manager shows a blank partition with an error: "dynamic invalid
There is also an option to convert to basic disk, with a warning that it will destroy all files. :-(
And device manager shows disk name.
thanks
Gordon

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 5232
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: my 1TB USB disk says dynamic invalid, but nothing when mounted

#2 Post by cgrenier »

What is the result with TestDisk ?

Post Reply