Cannot run TestDisk (Linux)

Using TestDisk to undelete files
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
greetp
Posts: 1
Joined: 09 Mar 2012, 23:31

Cannot run TestDisk (Linux)

#1 Post by greetp » 09 Mar 2012, 23:36

Hi,

I'm struggling to run Testdisk.

Grateful if anyone can advise exactly where I extract the files & how I execute them in Root.

Many thanks for any help

Phil (Linux newbie)

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 4730
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Cannot run TestDisk (Linux)

#2 Post by cgrenier » 10 Mar 2012, 09:49

Try

Code: Select all

wget -N http://www.cgsecurity.org/testdisk-6.14-WIP.linux26.tar.bz2
tar xjf testdisk-6.14-WIP.linux26.tar.bz2
cd testdisk-6.14-WIP
sudo ./testdisk_static
sudo will asked you for your user password. If you can't use sudo on your system, run "su -", type your root password,
go in testdisk-6.14-WIP directory using the cd command and run "./testdisk_static"

rwoody
Posts: 2
Joined: 28 Apr 2012, 22:45

Re: Cannot run TestDisk (Linux)

#3 Post by rwoody » 28 Apr 2012, 23:04

I'm also having Linux issues -
The version loaded:testdisk-6.14-WIP.linux26.tar.bz2 (I downloaded decompressed and installed the folder/contents direct to my Linux root)

I have the file system loaded - My kernel is :Linux 2.6.18-238.12.1.el5.centos.plus

Via the shell I've tried the following:
cd testdisk-6.14-WIP
[root@xxxx-xxxx testdisk-6.14-WIP]#
testdisk-6.14-WIP]# su - ./testdisk_static
su: user ./testdisk_static does not exist

Checking the /help file in su - it states - should assume root but apparently it does not so I tried the following, but it did not request my password (maybe due to the fact I'm logged in as root? :

testdisk-6.14-WIP]# su root ./testdisk_static
./testdisk_static: ./testdisk_static: cannot execute binary file

Any suggestions? I have a bunch of mp3 files that were deleted in error and I'm trying to recover them. Really need to figure this out.

Thanks in advance for such a great option (if I can get it to run)

Ruth

User avatar
remy
Posts: 457
Joined: 25 Mar 2012, 10:21
Location: Strasbourg, France.
Contact:

Re: Cannot run TestDisk (Linux)

#4 Post by remy » 01 May 2012, 17:34

when in testdisk folder, what's the result of

Code: Select all

ls -l testdisk_static 

rwoody
Posts: 2
Joined: 28 Apr 2012, 22:45

Re: Cannot run TestDisk (Linux)

#5 Post by rwoody » 12 Jul 2012, 17:55

Sorry, I don't speak or read French- but I gave up. Luckily I found an old back up and was able to restore 90% of the 6000 files that were deleted. I would really like to have this on the server for future events. Maybe I'll try again in the future.

Ruth

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest