Disk identification...please wait

Using PhotoRec to recover lost data
Post Reply
Message
Author
Nuishi333
Posts: 1
Joined: 18 Sep 2012, 06:04

Disk identification...please wait

#1 Post by Nuishi333 » 18 Sep 2012, 06:41

Greetings,

I have an internal SATA HD from an old crashed system (Vista), which sounds like it is spinning up ok, plugged into my new computer (Win 7) via USB. Explorer shows Local Disk (C:), CD Drive (D:), and Removable Disk (E:) of the host computer as usual. It also shows Local Disk (F:) with no information (right clicking for properties is taking forever...I'm still waiting) and RECOVERY (G:) which shows 1.98GB of 12.6GB free space from the USB connected HD. At one point I got an error message saying something about a cyclic error (?) and another time I was informed that I need to format the drive to put it to use. Mostly my machine just thinks about telling me something when I try to access the (F:) drive, yet never does. It looks to me like I have about 10GB of info on RECOVERY (G:), but when I open it, I find barely anything. I am ultimately attempting to recover photos from the SATA drive, all else is dispensable.

Anyway, I tried running Photorec and TestDisk, but I get stuck at the initial "please wait" with a prompt indifferent to my keyboard mashing.

I am puterstupid, please lend some advice after your eye-rolling. Thanks in advance!

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3330
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Disk identification...please wait

#2 Post by cgrenier » 19 Sep 2012, 07:05

Disconnect all unnecessary drive, dvd reader, USB card reader
Connect the damaged disk via SATA instead of USB
Does it work better ? If it's not the case, try to clone the disk to a new empty one as described in
http://www.cgsecurity.org/wiki/Damaged_Hard_Disk

Good luck

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests