EXT4 partition lost on a Software Raid array

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 3
Joined: 29 Sep 2012, 15:49

EXT4 partition lost on a Software Raid array

#1 Post by dhitchcock »

* I'm cross posting in the File Recovery forum, because I'm desperately trying both.

I have 3 1.5TB drives in a Linux software raid 5 array. While I was copying files from it, I started getting I/O errors and discovered the array had dropped to only one drive. There doesn't seem to be anything wrong with any of the drives, so I re-created the array fine, but the filesystem is damaged,

fdisk -l /dev/md0 : Disk /dev/md0 doesn't contain a valid partition table

When I run testdisk, it finds like a hundred random partitions of NTFS, Fat16, Fat12, all sorts of odd things. It does see what I assume is the one I want:

Linux 365921095 0 1 1098490310 1 4 5860553728
EXT4 Large file Sparse superblock Recover, 3000 GB / 2794 GiB

but that is in the "The following partitions can't be recovered:" list.

Here is the full log. https://dl.dropbox.com/u/355305/testdisk.log

Looking for any suggestions, or just a confirmation from an expert if it's really too far gone. I can't seem to wipe the drives and start over while I cling to this tiny hope of saving the data!