Fat32 repair

Using TestDisk to repair the filesystem
Post Reply
Message
Author
Shawn408
Posts: 1
Joined: 03 Oct 2012, 04:29

Fat32 repair

#1 Post by Shawn408 » 03 Oct 2012, 04:43

Hi there everyone. I'm would so extremely appreciative of any insight anyone can give me into my problem. Here's my situation:

- 1 TB WD external hard drive, FAT32
- Windows 7 PC

A few files became unreadable (wouldn't open in the regular program). So tried to repair the issue with chkdsk, checking the box to repair any errors it found.

Big mistake.

Now, instead of just a few files being unreadable, nearly the whole drive is. I see my original top level directory structure, but most of the directories are now not recognized by Windows as files. I double click them, and I get the window that asks me what program I want to open the file with.

The thing is, I know that most of my files are there. I used photorec, and it found millions of files, and started to recover them. The problem is that I had something like 550 GB of data on that drive, of all types, and now the files no longer have their correct names. So sorting all of that out is a monumental task, although far better than complete data loss.

So I think what I need to do is repair my FAT. I read the documentation, and I think testdisk can do this, but I'm not sure how. I found this link:

http://www.cgsecurity.org/wiki/Advanced_FAT_Repair

About repairing a FAT boot sector, which leads me to my question. This drive doesn't have a boot sector. It's an external drive that contains on OS. So given that, here's how I've tried to proceed:

- Start at disc selection screen, where I see WD external listed. Select that, hit enter
- Choose Intel as my partition table type
- Analyse... and I get read error. If I choose quick search, more read errors. But Windows is able to read the drive, and can even show me a handful of uncorrupted files
- Or I can choose Advanced, and get no partition available


So, gentlefolk, my question to you is... am I totally out of luck here? Is my best option to use photorec and sort things out myself as best I can? Do I have a hope of repairing my FAT and making things as they were? Is there a backup of my FAT I can use?

What additional information can I provide?

THANK YOU THANK YOU THANK YOU to anyone who takes pity on me. I promise I will try to pay it forward!

Shawn

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3569
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Fat32 repair

#2 Post by cgrenier » 13 Oct 2012, 14:54

Run latest PhotoRec 6.14-WIP, enable the expert mode, start a search, work on the whole space, try the FAT unformat,
use the default options if asked.
Be carefull to store the recovered files on another disk. PhotoRec should be able to recover your files with the original filenames this way.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests