Western Digital 3TB exFat GUID

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 2
Joined: 22 Oct 2012, 22:39

Western Digital 3TB exFat GUID

#1 Post by altares »

Hello all,

I just bought a WD 3TB hdd and I built a simple partition scheme under Disk utility in Mac OSX: GUID with 1 exFat partition of full size (3TB).
Everything went ok and then I started filling it with my stuff.
1 day later, I tried accessing the HDD and it was no more present in the finder. I then went to disk utility and it showed the exFat partition as MS-DOS(FAT) with a rubbish name. It still does.
Now, I tried testDisk and eventually got my exFat displayed again with simply the quick search function. The problem is, when I try to write the partition down, nothing changes in the system. Disk utility still says there is no exFat partition and the MS-Dos one does not mount.
I rebooted and tried that multiple times without success (tried single user mode too).
I tried getting my files back but I only got the first gigabytes of them and not the full files so they are corrupted (my files are all > 4Gb).
Please, can you tell me what I need to do to have testDisk write down the table correctly?

Thank you!

Posts: 2
Joined: 22 Oct 2012, 22:39

Re: Western Digital 3TB exFat GUID

#2 Post by altares »

Anyone please?