My 8GB USB stick will only format to 8MB in Windows ...

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Post Reply
Message
Author
DeepCut
Posts: 1
Joined: 24 Oct 2012, 11:54

My 8GB USB stick will only format to 8MB in Windows ...

#1 Post by DeepCut » 24 Oct 2012, 12:11

Hello.

I have an 8GB USB stick that Windows insists has a capacity of 8MB all of a sudden.

I have tried using Gparted and a few other tools with no success.

I know that the CHS should be 16383-16-63 with a sector size of 512.

I have changed the geometry in TestDisk to reflect the above CHS.

I then wrote the MBR code to the stick.

I unplug the stick, then plug it back in.

I skip Windows offer to format it.

I run TestDisk and the stick is back to 8MB.

The stick is around 2 months old, is it dead or is there anything i can do ?


Thank you,

DC.

Sponsored links

Post Reply

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Google Adsense [Bot] and 6 guests