Did 'fsck' on wrong device

How to use TestDisk to recover lost partition
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 13 Nov 2012, 18:14

Did 'fsck' on wrong device

#1 Post by Imagoodguy »

To make a long story short I did:
fsck -t ext2 /dev/sda1 .... which is "/"

I was used to seeing hda and not sda. Here is the layout
hda1 = /
hda2 = swap
hda3 = /home

While booted on Slackware live iso I wanted to reformat a second
drive which had Ubuntu:
Sda1, 2, 5, 6 and 7.

Instead of 'fsck -t ext2 /dev/sda' I did 'fsck -t ext2 /dev/sdc'.
Don't ask why... temporary insanity. Perhaps death wish. Anyway
with a few seconds I realized what I did. Tried ^C, Esc and then
yanked the plug out of the wall.

I can access hdc3 (/home) but cannot access hdc1 (/). What I need
to do is at least access hdc1 in order to salvage what I can. Then
I'll somehow copy /home to a spare disk.

Can Test-disk aid me in any way ?