Page 1 of 1

Corrupt RAID10 after BIOS update

Posted: 14 Nov 2012, 16:39
by DaFre
Hi all,

Since last Thursday I'm trying to fix my RAID10 partition that disappeared after a BIOS update.
The RAID10 consists of 4 ST3000DM001 (Seagate Baracuda) disks. It was formatted as NTFS with a GPT. The partition name was "Data". I'm fairly new to TestDisk.

What I've done:
- Recreated the RAID array via Intel RAID configuration utility (CTR+I at boot).
- The disk reappeared in Windows as RAW and uninitialized.
- I initialized the disk (stupid idea i guess :? ).
- I've ran TestDisk several times with different parameters but after the search it always reported that the "Data" partition could not be recovered.

Are these the correct steps or am I looking at the wrong partition trying to recover?
At the moment I don't have any screenshots but i would like to have some advice about the parameters i need to choose to run testdisk to be succesful since it takes about 24 hours to do a quick search.
(Parameters like sector size, partition table type (it suggests EFI GPT),...).

If I forgot to mention some crucial information please let me know and I will be happy to provide it! ;)

Thanks in advance!

Re: Corrupt RAID10 after BIOS update

Posted: 14 Nov 2012, 19:08
by DaFre
Here's an update.
I changed the sector size to 4096 and when I ran testdisk again I was able to find the structure right away.
Unfortunately when I tried to write the partition table I got the following message: "Partition: write error".
I did not perform a deep search.

Any suggestions?

Thanks in advance!

*EDIT*: It looks like the disk is read only. I booted from PartedMagic boot CD and when i try to access the disk i get the following message: "Write access for this media is not available. TestDisk won't be able to modify it."
I didn't make any adjustments to the drive. I only initialized it.

Any suggestions?


Re: Corrupt RAID10 after BIOS update

Posted: 17 Nov 2012, 19:11
by DaFre
Anyone any suggestions?