Incorrect disk size, unable to use SATA

Using TestDisk to repair the filesystem
Post Reply
Message
Author
OrangeSunnyboy
Posts: 1
Joined: 03 Dec 2012, 17:20

Incorrect disk size, unable to use SATA

#1 Post by OrangeSunnyboy » 03 Dec 2012, 18:06

Hey everyone,

I have a similar problem to ennyoueffsea that I'm hoping to get some help with. I have a 500Gb WD elements portable HDD (ADBABV5000ABK-00) which has inexplicably stopped working. Windows explorer and Chkdsk are able to transiently recognise that there is a HDD of some description connected however explorer prompts me to format the disk and chkdsk was unsuccessful. Recovery programs like Recuva aren't able to sense the drive at all.

In any case, when I ran testdisk, the program gave an erroneous HDD capacity (2199 GB/2047 Gib). Upon googling this phenomenon, I discovered that the solution is to plug the drive in via SATA, however, when I popped the enclosure of the hard drive open I discovered that there is no SATA port and that the micro usb port is in fact permanently affixed to the hard drive.

I was wondering if you guys had any suggestions on what my next step should be (barring a data recovery service)?
I considered purchasing a powered USB hub but I don't think that will remedy the problem.

Thanks in advance for any assistance you can provide!

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3573
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: Incorrect disk size, unable to use SATA

#2 Post by cgrenier » 24 Dec 2012, 08:04

Unfortunately data recovery service is the only solution when a wrong disk capacity is reported.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest