Actual Disk doesn't see partition but VHD does?

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Kel007
Posts: 1
Joined: 05 Dec 2012, 15:10

Actual Disk doesn't see partition but VHD does?

#1 Post by Kel007 » 05 Dec 2012, 16:05

I took a VHD of the bad disk (using Disk2VHD) and mounted it on a Hyper-V (Win7). The VHD was 3.9 GB. I then ran TestDisk on that VHD (to see how it works prior to running on 'real' disk) and it listed the bad NTFS partition with the contents of the partition 'mostly' correctly (some files were missing). Weird thing is, contents in there are appx 50 GB but VHD is only 3.9 GB, but it does list them. I tried to salvage them from VHD, but they're still corrupt. I attempted to Write to save structure, it asked to reboot, but still didn't work. it shows drive on My Comp but clicking gives an error.

Once I felt comfortable with the menus of TestDisk, I ran it on the 'real' drive but it can't find the NTFS partition on the real drive. It only shows two FAT16 partitions and if I perform a Quick Search and Deeper Search, both result empty. The real drive is connected to an XP machine.

Here are screenshots first is VHD, second is real drive, third is after performing Deeper Search on real drive:
TestDisk_1.PNG
TestDisk on VHD
TestDisk_1.PNG (21.59 KiB) Viewed 778 times
TestDisk_2.PNG
TestDisk on real drive
TestDisk_2.PNG (16.95 KiB) Viewed 778 times
TestDisk_3.PNG
after running Deeper Search on real drive
TestDisk_3.PNG (16.04 KiB) Viewed 778 times
Any ideas why the VHD of the bad drive shows the NTFS directory and the real drive doesn't find it?

Thanks!

Kel

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests