CF memory card FAT disappeared; replaced with ancient one

Using TestDisk to repair the filesystem
Post Reply
Message
Author
ACard
Posts: 2
Joined: 05 Dec 2012, 19:25

CF memory card FAT disappeared; replaced with ancient one

#1 Post by ACard » 05 Dec 2012, 22:19

It would be great if TestDisk could deal with MBR issues like the following on memory cards/sticks as well as hard disks, but maybe that functionality isn’t available yet – TestDisk (both 6.13 and 6.14) seems to misreport the geometry of memory cards. My issue:

After successfully transferring files in this way a number of times before, a Lexar 64MB CF card inserted into a card reader displayed 2 folders and 1 file, total 512 bytes, instead of a number of folders/files totalling 42MB – which is still the amount of space reported in use on the drive. The three remaining items are all a couple of years old, so it seems like the MBR has become corrupt and an old backup has been dusted off.

TestDisk only sees a couple of deleted files – also from a couple of years ago – and these aren’t needed. What I would like to be able to do is restore the current contents (which include some data files I don’t think PhotoRec would find).

TestDisk gives the following warnings: Number of heads/cylinder mismatches 4 (FAT) != 255 (HD) and Number of sectors per track mismatches 32 (FAT) !=63 (HD). And it gives similar warnings with the working cards I tried, too – a 1GB SD and a 16MB XD. So I’m very wary of trying anything that might write to the card, such as Rebuild BS. It lists current partition structure as 1, P, FAT16, >32M, 0, 0, 33, 7, 206, 6, 125407, [NO NAME], and says ‘Warning: Bad ending cylinder (CHS and LBA don’t match), No partition is bootable’.

I ran Chkdsk without /F and it reported errors on one of the two folders currently visible. Also – rather ominously, as I thought it wasn’t supposed to make any changes without /F – it said ‘Removing trailing folder entries from \’. It offered to convert lost chains to files, which I didn’t do. It said doing so would add 46360576 bytes of free disk space. NB. I ran Chkdsk after TestDisk.

Any help or thoughts would be appreciated.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3413
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: CF memory card FAT disappeared; replaced with ancient on

#2 Post by cgrenier » 24 Dec 2012, 08:14

The warnings about the geometry are only warnings, not errors.
TestDisk get the disk geometry from the OS but you can use Head and Sector in the Geometry menu to force it.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests