mft & mft mirror bad - any chance to get the data back?

Using TestDisk to repair the filesystem
Post Reply
Message
Author
brightsim
Posts: 1
Joined: 13 Dec 2012, 21:23

mft & mft mirror bad - any chance to get the data back?

#1 Post by brightsim » 13 Dec 2012, 21:42

Hi,

Even though I have fallen victim to some disk failures it seems I had always been quite fortunate with regards to what I was able to recover straight away - some corrupted files but that was it mostly.
Today, I had the brilliant idea to put some quite important data on my external disk to free up some space on my notebook since my desktop failed to boot - and of course it died on me...

First, MINT 13 complained about not being able to mount the disk when I wanted to copy the data back onto my notebook, telling me to run chkdsk - which in a state of panic I did. chkdsk failed to recover the MFT and now I am dealing with the mess that is left of my filesystem. I tried Get Data Back for NTFS and using the standard options only was able to view one folder in the final step (default settings).

Now I am reading up on what I can do and ended up with TestDisk - my initial attempt to recover the MFT failed (mft & mft mirror bad). For diagnostics, I am now running a deep search on my partitions. Before that I had a brief look at "rebuild boot sector", but aborted since it took me more than half an hour to reach 1% (it's a 1TB usb3 disk).

The current status is that in the trial version of get data back it doesn't show any data anymore, I have not written anything to the disk and can't mount whatsoever.

This is my output so far for the partition analysis:

Code: Select all

Disk /dev/sdc - 1000 GB / 931 GiB - CHS 121602 255 63
Analyse cylinder 90477/121601: 74%


  HPFS - NTFS              0  32 33 121601  25 24 1953519616 [Externe Platte]
check_FAT: can't read FAT boot sector
Invalid FAT boot sector
 0 D FAT32                198266  29  1 464356  47 22 4274737006
  FAT32                198266  29  1 464356  47 22 4274737006
Invalid FAT boot sector
 0 D FAT16 <32M           98160 150 44 330021 231 59 3724852084
  FAT16 <32M           98160 150 44 330021 231 59 3724852084
Could anyone tell me what to run and in what order to proceed to maybe get the whole thing working again? gparted shows the disk and the closure by the way (if that is of any relevance...).

Thanks a lot already for every reply, this is killing me right now - usually I would never store any crucial data on just one disk, but since my desktop was giving me a hard time and I needed to get work done, I just hoped for the best...

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests