WD Err 'Not Initialized'

How to use TestDisk to recover lost partition
Post Reply
Message
Author
UserNew
Posts: 4
Joined: 17 Mar 2012, 13:27

WD Err 'Not Initialized'

#1 Post by UserNew » 17 Mar 2012, 13:38

Hi,

I am having 'WD Elements' of 1 tb, using for more than a year, without any problem.

Suddenly, it stopped working, yesterday. USB detects it, but MyComputer doesn't show Drive Letter. And Disk Management shows as 'Not Initialized'.

'Data Lifeguard Diagnostic' (diagnosis s/w) from WD, says Pass for Quick Test.

When tried with 'testdisk-6.13', it complaints for 'Read Error' for each cyl read, following is the log.

I am having Vista Enterprise (SP2).

My WD came pre-formatted, most probably NTFS.

Appreciate the help, as HDD contains efforts of 4-5 years.

================================================================

Sat Mar 17 10:39:47 2012
Command line: TestDisk

TestDisk 6.13, Data Recovery Utility, November 2011
Christophe GRENIER <grenier@cgsecurity.org>
http://www.cgsecurity.org
OS: Windows Vista (6002) SP2
Compiler: GCC 4.3, Cygwin 1007.7
Compilation date: 2011-11-15T08:36:54
ext2fs lib: 1.41.8, ntfs lib: 10:0:0, reiserfs lib: 0.3.1-rc8, ewf lib: 20100226
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sda)=160041885696
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(/dev/sdb)=1000202043392
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive0)=160041885696
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\PhysicalDrive1)=1000202043392
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\C:)=151448977408
filewin32_getfilesize(\\.\D:) GetFileSize err Incorrect function.

filewin32_setfilepointer(\\.\D:) SetFilePointer err Incorrect function.

Warning: can't get size for \\.\D:
disk_get_size_win32 IOCTL_DISK_GET_LENGTH_INFO(\\.\S:)=8589934592
file_pread(4,1,buffer,312592769(19457/254/63)) lseek err Invalid argument
file_pread(5,1,buffer,1953520064(121600/254/63)) lseek err Invalid argument
Hard disk list
Disk /dev/sda - 160 GB / 149 GiB - CHS 19457 255 63, sector size=512 - ST916041 2AS, S/N:V51GFM1A, FW:0006
Disk /dev/sdb - 1000 GB / 931 GiB - CHS 121600 255 63, sector size=512 - WD Elements 1023, S/N:WXH0AC9H7564, FW:2005

Partition table type (auto): Intel
Partition table type (auto): Intel
Disk /dev/sdb - 1000 GB / 931 GiB - WD Elements 1023
Partition table type: Intel

Analyse Disk /dev/sdb - 1000 GB / 931 GiB - CHS 121600 255 63
Current partition structure:

Partition: Read error
Ask the user for vista mode
file_pread(5,1,buffer,1953504000(121600/0/1)) read err: Invalid argument
Allow partial last cylinder : Yes
search_vista_part: 1

search_part()
Disk /dev/sdb - 1000 GB / 931 GiB - CHS 121600 255 63
file_pread(5,8,buffer,32(0/0/33)) read err: Invalid argument
file_pread(5,8,buffer,40(0/0/41)) read err: Invalid argument
file_pread(5,3,buffer,48(0/0/49)) read err: Invalid argument
file_pread(5,3,buffer,95(0/1/33)) read err: Invalid argument
file_pread(5,8,buffer,111(0/1/49)) read err: Invalid argument
file_pread(5,11,buffer,158(0/2/33)) read err: Invalid argument
file_pread(5,2,buffer,2080(0/33/2)) read err: Invalid argument
file_pread(5,2,buffer,51(0/0/52)) read err: Invalid argument
file_pread(5,2,buffer,98(0/1/36)) read err: Invalid argument
file_pread(5,2,buffer,119(0/1/57)) read err: Invalid argument
file_pread(5,2,buffer,169(0/2/44)) read err: Invalid argument
file_pread(5,2,buffer,2082(0/33/4)) read err: Invalid argument
file_pread(5,8,buffer,63(0/1/1)) read err: Invalid argument
file_pread(5,8,buffer,71(0/1/9)) read err: Invalid argument
file_pread(5,3,buffer,79(0/1/17)) read err: Invalid argument
file_pread(5,3,buffer,126(0/2/1)) read err: Invalid argument
file_pread(5,8,buffer,142(0/2/17)) read err: Invalid argument
file_pread(5,11,buffer,189(0/3/1)) read err: Invalid argument
file_pread(5,2,buffer,2111(0/33/33)) read err: Invalid argument
file_pread(5,8,buffer,1008(0/16/1)) read err: Invalid argument
file_pread(5,8,buffer,1016(0/16/9)) read err: Invalid argument
file_pread(5,3,buffer,1024(0/16/17)) read err: Invalid argument
file_pread(5,3,buffer,1071(0/17/1)) read err: Invalid argument
file_pread(5,8,buffer,1087(0/17/17)) read err: Invalid argument
file_pread(5,11,buffer,1134(0/18/1)) read err: Invalid argument
file_pread(5,2,buffer,3056(0/48/33)) read err: Invalid argument
file_pread(5,5,buffer,1074(0/17/4)) read err: Invalid argument
.
.
.
.
.
.
file_pread(5,2,buffer,394060433(24529/32/33)) read err: Invalid argument
Search for partition aborted

Results

interface_write()

No partition found or selected for recovery
simulate write!

write_mbr_i386: starting...
file_pread(5,1,buffer,0(0/0/1)) read err: Invalid argument

Partition: Read error
Store new MBR code
write_all_log_i386: starting...
No extended partition

TestDisk exited normally.


===========================================================================

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: WD Err 'Not Initialized'

#2 Post by Fiona » 18 Mar 2012, 11:29

Using a disk in windows since W2k, it must be initialised.
Windows writes a signatur of 4 bytes into your partition table/MBR.
I've experienced problems recover data in windows if disk was not initialized.
Even other data recovery software was not able to.

Your case looks like that you only get read errors.
Probably you're not even able to initialize your disk.
First try might be to get rid of errors.
Can you remove it from your enclosure and check it internally?

UserNew
Posts: 4
Joined: 17 Mar 2012, 13:27

Re: WD Err 'Not Initialized'

#3 Post by UserNew » 18 Mar 2012, 12:22

First, Thanks Very Much, Fiona!

To get better idea about the problem,
(a) is it a connection problem?
(b) or anything has corrupted the MBR, (i.e. Virus)?
(c) any other option?

By the way, removing HDD from its case will void warranty?

I really need the data, I will surely proceed with your suggestion.

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: WD Err 'Not Initialized'

#4 Post by Fiona » 18 Mar 2012, 20:02

If you remove your disk from its case will void warranty!
Nobody can judge your problem exactly.
That's why a diagnose might be important to figure it out.
or anything has corrupted the MBR, (i.e. Virus)?
I cant't answer this question.
Until yet, there are read errors.
I've no idea how many?
My WD came pre-formatted, most probably NTFS.
Are you sure?
Mostly, external disks are FAT32 preformatted.
NTFS formatted?
Do they need a permission or license from Microsoft?

We've got some cases of external disks, which were encrypted.
Like in my post here;
http://forum.cgsecurity.org/phpBB3/repa ... .html#p814
Would it be possible in your case also?

UserNew
Posts: 4
Joined: 17 Mar 2012, 13:27

Re: WD Err 'Not Initialized'

#5 Post by UserNew » 19 Mar 2012, 02:42

Thanks Fiona, the help is very much appreciated!

I'm not sure about NTFS/FAT, I do recon is it wasn't formatted by me, when I started with it.

With respect to Encryption, there isn't any explicit, from my-side. How can I check, if it is factory configured (h/w or s/w)?

Currently I'm at client's place for couple of days, I'll proceed with removing the case, on my return. Will update you with the progress.

Thanks Million!

Take Care.

Warm Regards.

UserNew
Posts: 4
Joined: 17 Mar 2012, 13:27

Re: WD Err 'Not Initialized'

#6 Post by UserNew » 05 Apr 2012, 09:54

Hi Fiona,

I tried finding appropriate connector for the HDD, I mean after removing the case. But no luck!

Anyways, I have dropped idea of Recovery, as I got some of the data stored somewhere else.

Now the problem is I am not able to format it.

Disk Management says "The Media is write protected", after the first window "Initialize Disk" (i.e. Partition Style).

Does it mean the disk is dead?

:(

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests