Page 1 of 1

Lost HFS+ Partition in Windows

Posted: 31 Dec 2012, 19:55
by Shreds
Hi all,

Hopefully this problem is sufficiently complex to merit a post-I've tried the normal partition recovery steps for a FAT32 or NTFS partition, but I seem to have hit a wall at the last step. Anyway, some background:

I run Windows 7 with boot camp on a MacBook Pro with two internal hdds, with Lion on partition1 of the 1st drive and Windows7 on partition2 of the second drive. Partition1 of drive 2 is an HFS+ partition used for file storage for both operating systems, accessed within Windows7 using 3rd party software MacDrive. Both hdds use GPT.

While booted into Windows7, I was formatting a USB drive to install Windows on another computer, I selected the storage partition (part1, disk2) by mistake within diskpart and "cleaned" it before I noticed I had messed up. Windows7 no longer sees the partition, however the good news is that everything reads normally from within MacOS, so I can still get to my files.

Since the problem originated and persists in Windows7, I downloaded the 64 bit version of Testdisk for windows and proceeded to follow the step-by-step in attempts to restore the partition to the Windows7 partition table. Things work well until the final step, at which point Testdisk gets an error and MacDrive pops up warning that I'm trying to edit an HFS+ partition using windows utilities and asks if I want to use the MacDrive disk utility to repair the disk. Doing so does nothing to fix the issue. How can I get around MacDrive to get the partition working properly again within Windows7? I would poke around more, but I'm worried I will mess something up and lose my ability to access the partition in OSX if I proceed on my own.

Thanks in advance and happy new year!