testdisk o.k., aber kein mbr Debian und Windows xp

TestDisk benutzen um verlorene Partitionen wiederherzustellen
Post Reply
Message
Author
boleslav65
Posts: 2
Joined: 18 Jan 2013, 20:23

testdisk o.k., aber kein mbr Debian und Windows xp

#1 Post by boleslav65 » 20 Jan 2013, 22:34

Hallo,
vielleicht kann hier jemand helfen. Ich hatte versucht, ob ich windows xp in einer freien logischen Partition von linux (debian 6.03) installieren kann. Das war dumm. Windows machte irgendwas mit den Partitionen, löschte und erstellte neue, aber nichts ging. Darauf habe ich diese Partitionen über die Windows Installations-cd wieder gelöscht und mit testdisk (wunderbares Programm) alles gerettet, habe die extended partition, die plötzlich zu groß war, verkleinert mit sfdisk, so daß nun endlich auch gparted die Partitionen darstellt. testdisk meldete nun o.k., aber es gab keine Möglichkeit, von der Festplatte zu starten. Wenn der testdisk -mbr drauf war, wurde zwar f1234 angezeigt, aber kein start war möglich, bei Partition 3 kam "keine bootable partition". Ich kann den Rechner über die supergrub-2 disk starten, aber nicht von der Festplatte aus (WD 10ears 1 TB). Zwischen den Partitionen wurden nun auch Lücken gemeldet, die vorher nicht da waren.
Ich habe diese Lücken dann geschlossen über Debian und sfdisk. Darauf gab es wieder das Problem, daß gparted wegen "outside disk" nicht ging, nun auch fdisk nicht mehr aus demselben Grund. Wenn ich aber die Laufwerkeverwaltung bei Debian ansehe, ist alles drauf..Das gestartete System läuft wie immer, alle Dateien da (und exteren gesichert), alle Laufwerke mountbar und beschreibbar. Die extended partition wird als w95fat gemeldet, ein Verändern auf E brachte auch nichts. Über sfdisk konnte ich jetzt auch nicht mehr den Endzylinder der erweiterten Partition einstellen,
Nun habe ich die partition No. 3 mit windows xp installieren können, worauf windows lief, aber debian nur über supergrub. Dabei war dann aber ein Teil der extended weg. Ich habe sie nun über testdisk wiederhergestellt, alles ist lesbar, ferner die windows partition als bootable eingestellt, aber sie ist nicht mehr zu starten, auch nicht über supergrub. Bei Debian sehe ich die windows - Partition, aber sie wird wieder als linux ext4 geführt und kann über Debian nicht verändert werden. Natürlich wäre das Einfachste, die ganze disk zu erase und Alles neu zu machen, aber vielleicht gibt es ja einen einfachen Trick; irgendwo muß windows sich eingenistet haben, vielleicht gibt es ja irgendeinen sektor, den man löschen müßte?

Testdisk momentan (Alles grün, P 3 wieder Linux, s.o.)
disk /dev/sda - 1000 GB / 931 GiB - CHS 121602 255 63
1 * Linux 0 32 33 4112 243 35 66072576
2 P Linux 4112 243 36 15861 179 62 188743680
3 P Linux 15861 179 63 26435 148 17 169869312 [windows]
4 E extended LBA 26436 0 1 121601 254 63 1528841790
5 L Linux Swap 26436 23 20 26630 192 42 3127280
6 L Linux 26630 225 28 56620 234 62 481789952
7 L Linux 56621 1 1 83132 254 62 425915216
8 L Linux 83133 1 1 93518 254 60 166851024 [neuedaten]
9 L Linux 93519 1 1 98011 254 57 72179976
10 L Linux 98012 1 1 121600 254 57 378957216

Aber hier nun erstaunlicherweise ganz andere Angaben, nämlich von sfdisk -lu:

Disk /dev/sda: 121601 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

Device Boot Start End #sectors Id System
/dev/sda1 2048 66074623 66072576 83 Linux
/dev/sda2 66074624 254818303 188743680 83 Linux
/dev/sda3 * 254818304 424687615 169869312 7 HPFS/NTFS
/dev/sda4 424694340 1953536129 1528841790 f W95 Ext'd (LBA)
/dev/sda5 424695808 427823087 3127280 82 Linux swap / Solaris
/dev/sda6 427825152 909615103 481789952 83 Linux
/dev/sda7 909616428 1335531643 425915216 83 Linux
/dev/sda8 1335531708 1502382731 166851024 83 Linux
/dev/sda9 1502382798 1574562773 72179976 83 Linux
/dev/sda10 1574562843 1953520058 378957216 83 Linux

Disk /dev/sdd: 976 cylinders, 16 heads, 32 sectors/track
Units = sectors of 512 bytes, counting from 0

Wenn ich hier über sfdisk den Endsektor der extended korrigiere, kommt die Fehlermeldung, daß fat und linux den Wert unterschiedlich interpretierten und es kommt auch nichts Anderes heraus, s.o..

Oder gibt es das, daß die Festplatte im mbr den Geist aufgibt?

Wenn ein Experte einen Rat weiß, wäre ich dankbar. Sonst muß ich halt erase und neu installieren, habe nur Angst, daß die Festplatte möglicherweise defekt ist? Sie ist aber neu, keine Fehler mit smart und es gibt nun einen gewissen sportlichen Ehrgeiz.
Also erst einmal vielen Dank!

P. Seidel

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: testdisk o.k., aber kein mbr Debian und Windows xp

#2 Post by Fiona » 21 Jan 2013, 18:49

Bootprobleme und Datenrettung sind unterschiedlich!
Vor allem ist es so, TestDisk arbeitet nach Standard (Intel, Microsoft. Apple etc..).
TestDisk ist ein Tool welches in erster Linie mit der Partitionstabelle arbeitet, aber eigentlich alles im MBR unterstützt.
Bootprobleme weisen zumeist auf ein Problem im Bootloader (sind die ersten 446 Byte im MBR) und auf seine Signatur 2 Byte, das der MBR gültig ist hin.
Die Partitionstabelle ist mit 64 Byte nur ein Bestandteil.
TestDisk ist in der Lage einen neuen MBR-Code (Bootloader und Signatur) zu schreiben.
Manchmal wenn Bootmanager wie Grub installiert waren, welche den MBR und die Partitionstabelle modifizieren, war es nötig in TestDisk über das Menü Delete die Partitionsrablle zu löschen (In TestDisk Analyse kann ein Backup vorher von der Partitionastabelle gemacht werden) und erneut nach Partitionen suchen lassen und die Partitionstabelle neu zu schreiben.

Viele Grüße

Fiona

boleslav65
Posts: 2
Joined: 18 Jan 2013, 20:23

Re: testdisk o.k., aber kein mbr Debian und Windows xp

#3 Post by boleslav65 » 22 Jan 2013, 18:04

Also erst einmal vielen Dank für die prompte Reaktion! Und ich muß mich entschuldigen für meine Unwissenheit. Ich habe meinen Fehler entdeckt: Von der Annahme aufgrund der Fehlermeldungen ausgehend, daß der Fehler in der W95 extended zu suchen sei, habe ich mit quick search diese (die bei Testdisk zunächst ja nicht angezeigt ist) immer wieder falsch restauriert und so das Problem perpetuiert. Dann habe ich die Windows - Partition, die über Windows formatiert war, wieder als Linux-Partition angezeigt gesehen, das für den Fehler gehalten und gewaltsam zur ntfs-Partition umbenennen wollen (T). Dadurch wohl wurden die Einträge in der extended immer verrückter. Ich habe jetzt erst bei dem deeper search (hielt das vorher aus Unwissenheit nicht erneut für nötig, alles war ja grün und schien mir korrekt, dauert zweieinhalb Stunden) erst gesehen, daß die Windows - Partition ja nicht die ntfs-formatierte ehemalige Linux-Partition ist, sondern als eigene - alternative - Partition mit den gleichen Grenzen gefunden wird. Es bleibt aber der Eindruck, daß Windows zu viel eigenständig gemacht hat und sich mit Unix halt schlecht vertragen will.
Der Zustand jetzt ist der, daß im mbr f1234 zu sehen ist, daß ich da über 3 Windows starten kann, Debian aber nur über die Supergrub-disk, obwohl die Debian-Partition 1 als aktiv gekennzeichnet ist. Im advanced menu gibt es nur bei dieser windows-Partition 3 den button boot, ohne Fehlermeldung. - Mit diesem Zustand kann ich leben, vielleicht geht es mit einem bootleader über windows (windows versteht sich natürlich als C) noch besser.- Sonst würde ich in 1 Windows erneut installieren und drüber dann in gewohnter Weise Linux in 3, 2 bleibt home, dann würde vermutlich grub auch windows enthalten und alle BS direkt starbar sein. Der Zeitaufwand wäre weit geringer gewesen als so, aber ich habe viel gelernt und bedanke mich sehr. Fdisk und gparted funktionieren, bei der swap-Partition (erste in extended) war eine bad entrance angezeigt, scheint aber nichts auszumachen.
Sollte es eine Möglichkeit geben, den gesamten mbr zu restaurieren, wäre ich noch einmal für Hilfe dankbar.
Ein feines Programm!
P. Seidel

Post Reply

Who is online

Users browsing this forum: Google Adsense [Bot], Yahoo [Bot] and 0 guests