Drive started clicking during FAT repair

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read
Posts: 1
Joined: 19 Mar 2012, 17:26

Drive started clicking during FAT repair

#1 Post by atomicraven »

Hi there,

First off love the software. Great piece of programming!

I have an issue with an external 320g drive. It's a Samsung HD321KJ:

- The drive was dropped and data was not accessible. I used TestDisk to re-write the boot sector and the data became accessible.

- The drive worked for about 24 hours. Then I started getting either "the parameter is incorrect", or "no FAT table" error msgs while trying to access the drive.

- I Tried to repair the FAT table with TestDisk. At about 51 % the drive started clicking. I can no longer access or see the drive.

Any help would be Greatly appreciated!


User avatar
Posts: 2835
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Drive started clicking during FAT repair

#2 Post by Fiona »

Is your disk damaged?
Did your eventviewer (from your OS) got some issues about your disk?
Can you diagnose your disk using diagnostic tools from manufacturer.
Should be Seagate now.
Otherwise check the status of your Disk using CrystalDiskInfo portable;