Strange behaviour of Seagate ST3500320AS - Lost Partitions

How to use TestDisk to recover lost partition
Post Reply
Message
Author
badblock
Posts: 4
Joined: 18 Feb 2013, 11:11

Strange behaviour of Seagate ST3500320AS - Lost Partitions

#1 Post by badblock » 18 Feb 2013, 11:59

I shall try be as most concise as I can. :roll:

Hard Disk: Seagate ST3500320AS SATAII ,
4 partition on it
1. XP Sp3 ----30Gb
2. Data -------40Gb
3. extended with 2 logical partition
4. Win7-------45Gb
5. Data ------350Gb

Problem appear during copying files to 4-th partition ....Windows freeze and only thing which I can do is to turn off power. After that no more boot.

Running Test Disk ....following tips/steps from http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step
and have those messages:
"Bad starting head (CHS and LBA don`t match"
"Incorrect number of Heads/cylinder 255 (NTFS) !=14 (HD)

Warning: The current number of heads per cylinder is 14 but yhe correct value may be 255
When it analyze, TestDisk find partition but with same error for number of heads

Then I go to Geometry and find this:
Cylinders: 1107463
Heads: 14
Sectrors: 63
Sector size: 255

I change it to manufacturer numbers:
Cylinders: 60801
Heads: 255
Sectrors: 63
Sector size: 255

After "Analyze", TestDisk find all 4 partition, and second is marked as D /deleted/, and I can live with it.
Most concerning for me is partition no 4. /350 Gb/. After continue, and after "P" command I see files and directories on it. So, I decide to write that structure even second partition is marked as deleted.

Reboot ....Windows /from second disk, freshly instaled/ , affter allmost 45 minutes finally boot. Device manager see disk, but no in Disk Manager. After initializing it show me 2 partiton /4 and 5 in "extended enclosure" / as healthy. Unfortunately, no file system so I can`t reach my files.

Back to TestDisk but now with second disk attached. On is 2 partition - 1.win7 and second 450Gb empty logical NTFS partition - place to save data.

Test disk again find problems with number of cylinder/heads. Gemoetry again, and find partition but again with warning about numbers of head. Finally I managed to see files on most valuable partition where is about 220Gb data which I need to save.
I chose directory which I need ...press "C" for copy it and then try to select second disk, but can`t ... I try all letters which was given but every time it bring me back to selection.

Questions:
I have same tipe of disk in my sons computer and it work without problem. Can I switch PCB and try to save data ?
Is it possible to permanently put numbers for cylinder/heads/sectors/sector-size and what change it back?
How to "tell TestDisk" that I put another HD where I want to copy/save my data and how to select it?

Hopefully You shall understand what I wrote because English is not my native language :|

Any Help is most appreciated ...Thank You in advance

Sponsored links

badblock
Posts: 4
Joined: 18 Feb 2013, 11:11

Re: Strange behaviour of Seagate ST3500320AS - Lost Partitio

#2 Post by badblock » 26 Feb 2013, 11:10

Update!

I bring HD to my friend who use linux. His computer boot well without waiting and it recognize model and size of HD, but can`t see folders/files. I write this update because my friend saw something which is /his words/ "extremely strange"!

1. partition is visible in exact size /30Gb, NTFS, primary - boot/
2. partition is unalocated/unformated /free space 40Gb/ - obviously deleted D: partition
3. and 4. partition is visible in exact size too /45Gb and 350Gb/ << those two was logical drive in extended partition

but, 1. and 3. partition was shown with 14 heads and 4. with 255 heads /number of sectors and sector size was the same 63/512/. :?
His words again: "...newer heard about this, and I have no clue how this can happened or how this disk work at all ..."

we do not "touch" anything else, just turn it off to not make more damage :cry:

Lito
Posts: 83
Joined: 08 Sep 2012, 06:58

Re: Strange behaviour of Seagate ST3500320AS - Lost Partitio

#3 Post by Lito » 28 Feb 2013, 14:30

I am as surprised as your friend. Your set up should not work at all. It is not very easy to have two versions of Windows installed together, without some sort of boot manager. There many software packages to achieve that but you do not mention any.
Windows 7 in a logical partition??? I would have thought that it would need a Primary partition at the very least.

In any case you need another HDD (physical one, not made up). A HDD with at least the 350 GB that you are trying to copy (partition 4 or 5 depending how you look at it). The reason yo cannot copy files to partition 2 is because, as you already have said: it does not exist, it has been deleted (D). But if it did exist, it would be too small, because you have pointed that partition 2 was only 45 GB.

Run Testdisk to the point where you were able to List your files, and from there Copy them to another HDD that you already would have ready (Partitioned and Formatted). No need to Write the filesystem structure to the old HDD (Seagate) because you most likely would have to clean it.
With enough resources in your system you could install Virtual Box or similar sotware to run XP as guest system of Windows 7. Or from Windows 7 run something like Compatibility Mode, which is something I have not tried myself.
In any case you will need the Installation Disks for the two systems. You can also virtualize from Linux.

Best of luck

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Strange behaviour of Seagate ST3500320AS - Lost Partitio

#4 Post by Fiona » 01 Mar 2013, 09:11

Since Vista-Win-7/8 partitions are not aligned on cylinder boundary (intel-standard) anymore, but megabyte boundary.
So the geometry< values at disk are helping most and partition geometry has not as much significance if partitions created using windows vista/7/8.
Wrong geometry at disk can cause that partition are not recoverable because they overlap or testdisk doesn't find a vanished partition.
Please upload a screen from TestDisk and Analyse.
Normally, default values of a 3.5 inch disk are 16 heads per cylinder and 63 sectors per head.
Sector size is normally 512 bytes on newer disk, might be 4 k sectors.
2.5 inch disk are often 15 heads per cylinder.
Disk controller from motherboard (desktop PC) change this to 255 heads and 2.5 inch disks for laptops/notebooks often to 240 heads.
But sector size of 255 bytes looks absolutely wrong?
Please set your BIOS back to default and check your cable, to have a try to get normal values.

Fiona

Fiona

badblock
Posts: 4
Joined: 18 Feb 2013, 11:11

Re: Strange behaviour of Seagate ST3500320AS - Lost Partitio

#5 Post by badblock » 01 Mar 2013, 13:09

Thank You Lito and Fiona for Your reply!

@Lito, as Fiona said, Windows 7 can be anywhere on the Disks as far as botmgr is on boot partition. That was not issue at all. And Yes, Windows 7 automatically put Boot Manager where we chose which OS to boot.
I use 2 x 3.5 inch HD of same model/size.
I do not even try to copy on partition 2 at same disk but to other HD with 450Gb second partition. On first partition of that correct HD, was freshly installed Windows 7, just to be able to boot computer, run TestDisk and try to save data from damaged HD.
When I run TestDisk, it see both HD, ...when I Analyze damaged HD, I am able to see file/folders structure /P command/ but, unfortunately, when I use C command I am confused because I see all possible drive letters from A: to X: :? Also, all that drive letters when I chose one of them looks like they have same files on it.
How to chose second partition on correct HD :?:

@Fiona, when I went back to home, I shall try to catch/upload screen-shoot.
BTW, on Seagate site, I find that correct value for this model of HD is:
Cylinders: 60801
Heads: 255
Sectors: 63
Sector size: 512

Q. When I change those value, did I need to restart computer /because TestDisk said that/ or I can change it on the fly and run analyze again with different value :?:

One things more..just to clarify ...I am concerned just and only for 4-th partition and data on it.
1., 2. and 3. partition can be deleted AFAIK.

Data/Power Cables was brand-new, and I try it before connecting those HDs, so that was not issue.
PSU was more than strong enough ...GreenMax 750W Gigabyte
And Yes, You are wright, sector size is 512 ...my type-mistake.
Both HD was partitioned/formated from Windows 7 with AHCI enabled in BIOS.

I did not try it, but somwhere I read that I need to disable AHCI and use legacy instead. But that is step to use some other recovery tool. If I need I shall do it, even I am concerned shall Windows 7 boot-up at all when I change that.

Thank You both for Your reply.

Best regards

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests