No partition visible on SSD - has no endmark 0xaa55

How to use TestDisk to recover lost partition
Post Reply
Message
Author
epatten
Posts: 1
Joined: 13 Mar 2013, 22:51

No partition visible on SSD - has no endmark 0xaa55

#1 Post by epatten » 13 Mar 2013, 23:19

Hi all,

I have a Lenovo T61p that had an SSD drive install on it and Windows7 64 bit. It was working fit for months, but earlier this week it wouldn't boot up, saying that 'no operating system was found'. I've since tried many things, but to no avail. Any tips or hints are greatly appreciated. Here's a rough summary of what I've tried:

-W7 boot CD, when I go to system recovery options, it doesn't list an operating system
-- startup repair: just runs for hours and gets nowhere
-- System restore: can't find any to restore from
-- Windows memory diagnostic tool: gives me an error and says it can't run (I forget the specific error, could run it again to check if it's important).
-- Command prompt: loads to the C drive and lists the folders present. I can navigate through a limited amount (no access to user folders, probably because I had a password on it)

-Partition Wizard bood CD
-- it listed the entire drive as unallocated, and after a 14Hr deep scan, couldn't find anything

-Power Data Recovery boot CD
-- Lost partition recovery: after a quick scan and deep scan, it lists no partitions

-TestDisk, via PartedMagic on the ultimate boot CD
-- first it asks if it's bigger than 137GB, but it's a 128GB drive
-- Analyse: it lists no partitions, and says "partition sector doesn't have the endmark 0xaa55", after a quick and deeper scan, it still lists nothing
-- Advanced: it says no partition available, and lists no options

I've tried to search for posts with similar issues but had no luck.

Is it time for me to try the MBR code? Or is there something else I can try?

Thank you all in advance!

Eli

Sponsored links

Lito
Posts: 83
Joined: 08 Sep 2012, 06:58

Re: No partition visible on SSD - has no endmark 0xaa55

#2 Post by Lito » 21 Mar 2013, 12:40

Did you upgrade the HHD for the Lenovo T61p yourself?
Somewhere I read advise on how to make the upgrade with Seagate drives (I think). The recommendation was to use a USB adaptor to clone the HDD that comes installed from factory. If that was the case you could use the original disk whilst you look for a solution.
As for MiniTool Partition Wizard, I have version 7.6 for a while now. As far as i can tell there is two possible ways to "scan" a disk. One is a surface scan aimed at finding bad sectors or hardware faults. Not much point in running that.
The second way is a so called Partition Recovery which looks like an useful thing. But when run as per default it will not fix anything even if it found a partition. You have to select the option of fixing any errors it might find.
I never had to try it myself. My take however is that since this tool is free I could not in a month of Sundays programme myself some thing similar, I should respect their work. Mainly I use it for what it says in the tin: handle Disks and Partitions, for example to do a quicker wipe than Dban or to quickly examine a Disk. I downloaded the last version 7.7 and I think that the option to recover a partition ha been removed. Power Recovery Free version in the other hand only allows you to recover 1Gigabyte of data. No a lot of use unless you triyng to recover a few pictures from a card or USB pen.
Anyways, when you run the Windows 7 installation disk to repair the system, I think the C: drive you see is the CD or a Ram disk that Windows creates, that is why you cannot access yoour Users folders..
Parted Magic is a CD in it own right.
Sorry I have to go out now.
I suppose is not a lot of help. Sorry

Best of luck

Lito
Posts: 83
Joined: 08 Sep 2012, 06:58

Re: No partition visible on SSD - has no endmark 0xaa55

#3 Post by Lito » 21 Mar 2013, 14:36

I came back just to add a few links that might be of some use.
If you Google for "Partition sector doesn't have endmark 0xaa55" the first page in the list of hits is:

http://www.cgsecurity.org/wiki/Data_Recovery_Examples

If the Backup Boot Sector is shown as OK you could copy it over the missing or bad Boot Sector in the disk.
The Boot Sector can also be Rebuilt. There are instructions in the page.
It is scary stuff but if you are getting nowhere it might be worth your while.

It would be a sensible idea to clone the disk with GNU ddrescue before attempting something like that.
You can get very good deals on HDD of about the size of your SSD. A HDD of around 160 Gigs would fine (not SSD).
If you search this forum for Damaged Disks or in the TestDisk FAQ pages you will find intructions on how to do a clone. Hereafter I copy and paste from an earlier post, about a drive throwing the same error.

There is very good advice by a TestDisk Team member in this page:

http://forum.cgsecurity.org/phpBB3/usb- ... -t462.html

The main tip here seems to be scanning for Partition table type None for diagnostic purposes.

More clues and ideas in this page:

http://ubuntuforums.org/showthread.php?t=1590694

Very helpful hints and tips, here:

http://forum.piriform.com/index.php?showtopic=34355

From here you can get a Linux Live CD (Knoppix based) or Trial Recovery software.
Please note that there is a warning in the site about the Live CD being "experimental":

http://www.runtime.org/data-recovery-live-cd.htm

Another link that might throw some light so you can acomplish your task:

https://help.ubuntu.com/community/DataRecovery

You could also run PhotoRec before anything else, to scan for data to save, just in case.

If runnning TestDisk from Windows, remember to run it As Administrator.
If running from Linux run it as Root.

If you have valuable data might be you can try commercial software like Ultimate Restorer:

http://www.restorer-ultimate.com/

They also offer a trial of their sofware.

Best of luck

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests