Ext3 partition mounted as Ext2 at install. How to recover?

How to use TestDisk to recover lost partition
Post Reply
Message
Author
baronsamedi
Posts: 2
Joined: 08 Apr 2013, 19:20

Ext3 partition mounted as Ext2 at install. How to recover?

#1 Post by baronsamedi » 08 Apr 2013, 19:43

Hi guys.

I was installed Bodhi Linux and pointed the /home mounting point to my isual partition (dev/sda5), which has been in ext3 file system for years.

Somehow, the install decided to set it up as ext2 (I'd swear I didn't order it, but who knows). I am pretty sure the partition was not formatted though. Suddently the wholle /home is empty: I've lost all my data.

After some search, I went for the recovery process described here:

http://ubuntuforums.org/archive/index.p ... 45536.html
http://www.cyberciti.biz/tips/surviving ... lures.html

But still the data is missing.

I tried to log in through an older LMDE install I had in yet another partition, and the first time I got the message:

Code: Select all

fsck.ext3: Unable to resolve 'UUID...........
fsck died with exit status 8
But after that, any attempt to log in through the Bodhi install gets the /home empty, and through the LMDE install just makes the laptop screen go blank.

I am mostly playing TestDisk by ear, and learning as I go. So I haven't dared to do anything definite yet.

TestDisk sees al the partitions all right. Deeper search also lists the partition, marked "D", howerver.

Pressing "L: load backup" it says "No backup found!"
Pressing "P: list files" just shows the partition mostly emptly, except the few files created during the fateful install.

Any ideas? I'll be mostly reading the SC wiki while waiting, I guess, as an alternative to biting my nails off.

Sponsored links

User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Ext3 partition mounted as Ext2 at install. How to recove

#2 Post by Fiona » 08 Apr 2013, 20:30

You can run Deeper Search to have a try to find your ext3-partition.
If any ext3 partition is found, you can check it and press p to have a try to list your files?
If it doesn't find any, you'll probably need datarecovery software like PhotoRec or if you want to keep file names, commercial software.

Fiona

baronsamedi
Posts: 2
Joined: 08 Apr 2013, 19:20

Re: Ext3 partition mounted as Ext2 at install. How to recove

#3 Post by baronsamedi » 08 Apr 2013, 20:45

Thanks for the replay.

Pressing P shows the (very few) files in the partition as it is now, which are in fact the files created by the install when the partition was turned to ext2.

However, if I go "Anaiyse --> quick search --> list files" it says "Can't open filesysteme. Filesystem seems damaged".

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests