Raid0 partition found but not recovered Topic is solved

How to use TestDisk to recover lost partition
Message
Author
User avatar
Fiona
Posts: 2836
Joined: 18 Feb 2012, 17:19
Location: Ludwigsburg/Stuttgart - Germany

Re: Raid0 partition found but not recovered

#11 Post by Fiona » 03 May 2013, 07:17

It's like I already guessed, that your disk is listed wrong as a basic disk.
But after right click in the left sqare, you only can convert it to basic (Intel MBR) and dynamic.
It means, that your disk is already GPT.
So there is nothing to do.

Would it be possible to use msconfig?
Can you disable everything at startup?
Click on the tab services.
Activate hide microsoft services.
Disable all services too.
Restart your pc.
Repeat your diagnose.
If testdisk provides the results, please check that first unnecessary MS Data partition;
Results
P MS Data 43560 248359 204800
NTFS, blocksize=4096, 104 MB / 100 MiB
P MS Data 264192 7814045695 7813781504 [Stockage]
NTFS, blocksize=4096, 4000 GB / 3725 GiB
Use the left or right arrow key on your keyboard, to change it to D for Deleted
Should look like;

Results
D MS Data 43560 248359 204800
NTFS, blocksize=4096, 104 MB / 100 MiB
P MS Data 264192 7814045695 7813781504 [Stockage]
NTFS, blocksize=4096, 4000 GB / 3725 GiB


Press enter to confirm.
Have another try to write it to your partition table

Fiona

Sponsored links

User avatar
vsix
Posts: 12
Joined: 28 Apr 2013, 23:16
Location: Clermont-Ferrand - France

Re: Raid0 partition found but not recovered

#12 Post by vsix » 03 May 2013, 08:10

Thanks again Fiona, will try that this afternoon.

But I don't think there is a problem with services or startups programs : like I said when I tested to write my partition in "Intel partition" mode, it works and tell me that I have to reboot my PC. But it causes black screen at startup of my machine... If a service or a program block the GPT partition writing, I think it should block the Intel partition writing too.

If I have recreated my raid array in a wrong configuration (size of stripes for example) could I list, save and read datas on this partition? If no, then I'm sure about my raid config, but if yes... I can't confirm my array configuration and maybe it should be the problem.

User avatar
vsix
Posts: 12
Joined: 28 Apr 2013, 23:16
Location: Clermont-Ferrand - France

Re: Raid0 partition found but not recovered

#13 Post by vsix » 03 May 2013, 12:53

Exactly the same issue with diagnostic boot (Windows services, all startup programs disabled).
This is driving me crazy :shock:

User avatar
vsix
Posts: 12
Joined: 28 Apr 2013, 23:16
Location: Clermont-Ferrand - France

Re: Raid0 partition found but not recovered  Topic is solved

#14 Post by vsix » 03 May 2013, 21:46

Woaaw, my partition appeared! And I did nothing... WTF? Testdisk is magic? :lol:

Locked

Who is online

Users browsing this forum: No registered users and 0 guests