Can PhotoRec really recover from a quick erased CD-RW? Topic is solved

Using PhotoRec to recover lost data
Locked
Message
Author
CDRW
Posts: 4
Joined: 20 May 2013, 18:31

Can PhotoRec really recover from a quick erased CD-RW?

#1 Post by CDRW » 20 May 2013, 19:17

On the Wiki, it is stated that PhotoRec can recover from a quick erased CD-RW without need to modify the disc as long as you run PhotoRec Linux version.

I loaded PhotRec in Puppy Linux, but my quick blanked CD-RW does not appear in the PhotoRec drive list. Only the hard drives appear. No chance to see if my CD-RW is listed size as 0 or 2048 bytes because the CD drive is not listed at all.

In fact, the blank CD-RW is not even mounted by Linux. It cannot mount a blank disc. So how can PhotoRec see the blank disc when Linux cannot mount a blank disc?

I type into the command line:

Code: Select all

mount /dev/cdrom /media/cdrom -t iso9660 -o session=0
It gives the following error:
mount: block device /dev/scd0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd0,
missing codepage or helper program, or other error
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)
In some cases useful info is found in syslog - try
dmesg | tail or so
Is there something else I need to do to get Linux to mount the quick erased disc?

Sponsored links

CDRW
Posts: 4
Joined: 20 May 2013, 18:31

Re: Can PhotoRec really recover from a quick erased CD-RW?  Topic is solved

#2 Post by CDRW » 01 Aug 2013, 15:01

Here's an update:

I ran the Linux kernel 2.4 version of PhotoRec and the blank CD was recognised as 2048 bytes. I also ran it in Win XP and the drive was recognised as 2048 bytes too, so it must just be a problem with Puppy Linux or the kernel 2.6 version.

So it turns out that you don't need to use the Linux version afterall to get at a blanked CD, it shows up in Windows XP too.

The only way to recover the data was to re-burn a new fake TOC to the disc, the CD drive itself refused to read the blanked disc otherwise.

Locked

Who is online

Users browsing this forum: No registered users and 2 guests