Can't boot from drive

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Locked
Message
Author
Mannie
Posts: 1
Joined: 26 May 2013, 05:20

Can't boot from drive

#1 Post by Mannie »

This is a long story because I have no idea what is relevant & what is not.

I have an old AMD system with two hard disks:
ST380011A 80G IDE
ST3160827AS 160G SATA

Originally I ran WinXP which booted off ST380011A. I wanted to install Win7 but, as there was no way to automatically migrate apps from WinXP to Win7, I discovered a way to run the both OSes by changing a configuration item in the BIOS. If I switched on RAID in the BIOS it changed the boot order of the hard disks from IDE to SATA. So I installed Windows 7 successfully onto the SATA drive. If I wish to run XP I just switch off RAID in the BIOS & it boots XP off the IDE drive. This has worked well for a long time but a week ago I got the following error when turning on my PC:
Windows Boot Manager
Status: 0x000000e
The boot selection failed because because a required device is inaccessible


I searched web for fix but nothing worked.
If I boot into XP on IDE drive I appear to be able to access all my data on the SATA drive. I just can't boot from it.

By chance I tried the AVG rescue CD which had a copy of TestDisk on it when I ran it, TeskDisk found Incorrect number of heads/cylinder 16 (NTFS) !=255 (HD). This meant nothing to me other than there appeared to something wrong with hard disk. Anyway I couldn't find log file (because I was booting off CD?). So I ran TestDisk after booting PC in WinXP and got the following from the log file:
Analyse Disk /dev/sdb - 160 GB / 149 GiB - CHS 19457 255 63
Geometry from i386 MBR: head=16 sector=63
BAD_RS LBA=2048 32162
NTFS at 0/32/33
heads/cylinder 16 (NTFS) != 255 (HD)
BAD_RS LBA=206848 3293533
NTFS at 12/223/20
heads/cylinder 16 (NTFS) != 255 (HD)
Current partition structure:
Warning: number of heads/cylinder mismatches 16 (NTFS) != 255 (HD)
1 * HPFS - NTFS 0 32 33 12 223 19 204800 [System Reserved]

Bad relative sector.
Warning: number of heads/cylinder mismatches 16 (NTFS) != 255 (HD)
2 P HPFS - NTFS 12 223 20 19457 21 20 312371200

Bad relative sector.


I also got the following when doing a partition search:
search_part()
Disk /dev/sdb - 160 GB / 149 GiB - CHS 19457 255 63
NTFS at 0/1/1
filesystem size 312576641
sectors_per_cluster 32
mft_lcn 153170
mftmirr_lcn 154634
clusters_per_mft_record -10
clusters_per_index_record -12
HPFS - NTFS 0 1 1 19456 254 62 312576641
NTFS, blocksize=16384, 160 GB / 149 GiB
file_pread(5,2,buffer,312582144(19457/86/22)) lseek err Invalid argument
file_pread(5,1,buffer,312582144(19457/86/22)) lseek err Invalid argument
file_pread(5,8,buffer,312581823(19457/81/16)) lseek err Invalid argument
file_pread(5,1,buffer,312581823(19457/81/16)) lseek err Invalid argument
file_pread(5,8,buffer,312581951(19457/83/18)) lseek err Invalid argument
file_pread(5,8,buffer,312582079(19457/85/20)) lseek err Invalid argument
file_pread(5,1,buffer,312582143(19457/86/21)) lseek err Invalid argument
file_pread(5,1,buffer,312582144(19457/86/22)) lseek err Invalid argument
file_pread(5,14,buffer,312582145(19457/86/23)) lseek err Invalid argument
file_pread(5,3,buffer,312582159(19457/86/37)) lseek err Invalid argument
file_pread(5,3,buffer,312582206(19457/87/21)) lseek err Invalid argument
file_pread(5,8,buffer,312582222(19457/87/37)) lseek err Invalid argument
file_pread(5,11,buffer,312582269(19457/88/21)) lseek err Invalid argument
file_pread(5,2,buffer,312584191(19457/118/53)) lseek err Invalid argument
get_geometry_from_list_part_aux head=255 nbr=2
get_geometry_from_list_part_aux head=8 nbr=1
get_geometry_from_list_part_aux head=16 nbr=1
get_geometry_from_list_part_aux head=32 nbr=1
get_geometry_from_list_part_aux head=64 nbr=1
get_geometry_from_list_part_aux head=128 nbr=1
get_geometry_from_list_part_aux head=240 nbr=1
get_geometry_from_list_part_aux head=255 nbr=2

Results
* HPFS - NTFS 0 1 1 19456 254 63 312576642
NTFS, blocksize=16384, 160 GB / 149 GiB

Is there anything I can do fix the SATA drive with TestDisk? My main concern is ensuring that whatever I do does not cause me to lose all the data which still exists on the drive.

Any help would be greatly appreciated.

Sponsored links

Locked