photorec.sig and fidentify problem

Using PhotoRec to recover lost data
Message
Author
poofgone
Posts: 1
Joined: 28 Mar 2012, 14:21

photorec.sig and fidentify problem

#1 Postby poofgone » 28 Mar 2012, 15:00

I'm booting a PC from 'Ultimate Boot CD v5.0' media which includes a Linux-based distro of Parted Magic, which in turn includes PhotoRec v6.12. After launching Parted Magic, I am delivered to a rooted console.

I want to use PhotoRec to search for a file type that 1) is not included in the default list of recoverable file formats and 2) does not have an extension. I have run 'hexdump -C' against a sample file and received the following unique output string from the top line of the head:

|G\...m..x:.... t|

Based on this output, I have created a '.photorec.sig' file in the /root directory with root:root ownership, 644 privs, and the following single line of content:
custom 0 "G\\"

Following this, when I run 'fidentify' against the sample file, I was expecting 'custom' to be outputted instead of 'unknown' to confirm that the distinctive file type would be correctly identified when PhotoRec is executed; however, I continue to receive the 'unknown' output. This makes me suspect that the .photorec.sig file is not being acknowledged. Any thoughts on how to correct my mistake(s)? Thanks for your time and attention in advance.

Sponsored links

User avatar
cgrenier
Site Admin
Posts: 3070
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France
Contact:

Re: photorec.sig and fidentify problem

#2 Postby cgrenier » 29 Mar 2012, 06:26

Try using pPhotoRec 6.14-WIP

Code: Select all

wget -N http://www.cgsecurity.org/testdisk-6.14-WIP.linux26.tar.bz2
tar xjf testdisk-6.14-WIP.linux26.tar.bz2
cd testdisk-6.14-WIP
sudo ./photorec_static


Return to “File recovery”

Who is online

Users browsing this forum: No registered users and 0 guests