What's the best course of action here?

How to use TestDisk to recover lost partition
Post Reply
Message
Author
jpmurray
Posts: 1
Joined: 09 Jul 2013, 14:34

What's the best course of action here?

#1 Post by jpmurray » 09 Jul 2013, 15:01

Hi there,

I've used testdisk/photorec some times in the past for simple recovery, but right now I'm facing a situation that is a little more complex than what I've seen in the past, so I'm looking for advices!

So, here is the situation : yesterday at work, somebody installed Windows Server 2012 on one of our machine that previously worked in Ubuntu. Setup is simple : one 80gb HDD for the OS and two 1TB HDDs for data. So he went on and formatted the 80gb HDD and installed Windows Server. When it booted up, we discovered that windows used one of our data disk to write a 200 mb system partition leaving all the rest of the disk (and our data) on a unformatted space on the disk. First lesson learned (for him and myself, I wouldn't have done it either) : unplug all unnecessary disk when installing Windows Server... Now, onto trying to recover everything!

I've opened photorec : it's found 5781 files, and the list of recovered files totals to 5781, although it's stuck at sector 664249422/1953525168... I guess all the files are there, but it stuck somehow. It should be all right! But nope. I didn't knew about it, but photorec recover the files, but not the names and structure of files and in our case (it's recorded archives of radio shows) we REALLY want to be able to identify the files as they where!

So I've turned to testdisk : the partition type automatically selected is "none" and it does see the EXT3 partition with the correct name of the folder : sweet! Trying to browse the files or write it to the disk fail because I'm in the "none" type of partition. If I select the "intel" type, it sees the NTFS reserved partition that windows made, but not the EXT2. I"m right now doing a quick search, but I think I should't be expecting to find anything...

So there I am : the files are there, but I'd need to recover also the structure and name of files. Is there any way I could accomplish that? Or should I just be lucky that I've got the files without the name?

Thank you,
__
Jean-Philippe Murray

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests