TestDisk unable to find hard disk

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 10 Aug 2013, 14:21

TestDisk unable to find hard disk

#1 Post by thisbenguy »

Good morning, My wifes work computers HD crapped out and their IT gentlemans backup did not include most of her data (i.e. outlook contacts, spreadsheets from my documents). Being a good husband I thought I'd take a crack at getting them back for her for a "price to be named later".

The HD is a WD 250gb that had windows 7. I have an old windows laptop that I figured I would be able to put the effected drive in, run TestDisk and be able to move the data to an external HD. Not sure if it's pertinent, but the machine I'm using as the donor is/was an HP with windows xp.

I booted the windows machine with a Ububtu 12.04 live CD and acquired TestDisk from Synaptics.

When I run TestDisk it will only display the volume created by the Live CD "Disk /dev/sr0 ... ... DVDRAM".

I plugged in an external HD and ran TestDisk again to verify it's proper operation, and it found the external HD without issue.

Any assistance would be appreciated.


User avatar
Site Admin
Posts: 5422
Joined: 18 Feb 2012, 15:08
Location: Le Perreux Sur Marne, France

Re: TestDisk unable to find hard disk

#2 Post by cgrenier »

You need to run TestDisk as root, otherwise you are using a user account that don't have the right to access all the disks.
You should select sudo in TestDisk interface.