Very complicated problem with windows 7 recovery

How to use TestDisk to recover lost partition
Post Reply
Message
Author
Kavukamari
Posts: 1
Joined: 22 Sep 2013, 14:11

Very complicated problem with windows 7 recovery

#1 Post by Kavukamari » 22 Sep 2013, 14:28

I really need help.

recently my computer stopped booting properly (starts to flashing _), so I tried a boot repair disk on it, hours later, the disk had apparently done nothing, so I force shut down the computer to try something else (probably the biggest mistake here)

computer starts to the cd's boot but black screen afterward

I boot to bios, and my C partition is gone unlike I had seen before in BIOS where both C and D partitions were visible and accessible, and the RECOVERY partition that came with my asus drive is now visible instead

I boot up linux to recover my partitions, using testdisk. I recover the MBR because I thought it would help (possibly a mistake, I don't know what it did)

after a deep scan, I realize my c partition is still there, and all of my data is intact. I figure if I repair the partitions it will start up normally

can't repair partitions, I forget the error, but it was the cannot write the partition table one

I buy a new hard drive, and clone the first hard drive onto it for testing, there are red files in the recovery partition, I don't know what this means.

I've tried using ms-sys to write new boot sectors but I have no idea now it works. The new hard drive should be an exact copy of the other, but with a newly repaired partition table, an attempted boot addition to the OS drive because I didn't know what I was doing, and an attempted MBR fixing from both testdisk, and ms-sys which I don't know if either worked at all

however I don't know how to fix the booting, or how to set up the partition table.

In the new hard drive there are 4 partitions currently: RECOVERY, OS, DATA, and DATA

recovery is supposed to be hidden from use, OS is my C drive with windows installed on it, and tons of my data, it takes up 1/4 of the original HD's 640 GB space. the first DATA is my D drive, which was completely accessible all throughout my usage of linux, it fills the remaining 3/4 of the original HD's space. The second DATA is a new partition I added to take up what was remaining of the terabyte of space in the new hard drive, it's about 400 or so gigs, and it's completely empty because I just made it.

I don't know how boot sectors work. furthermore, I don't know what PRIMARY * BOOTABLE means, and which should be the primary bootable. I don't know how the partition table was set up before my recovery attempt.

My question, is does anyone know how I can fix this to just be how it was before I used the recovery CD which hid my C drive, and just go back to normal usage of my computer

this is driving me crazy

I might edit this later to add more information, because in my mixed depression and desperation I have no idea what I missed

Sponsored links

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest