another USB stick unreadable

Using TestDisk to repair the filesystem
Post Reply
Message
Author
JoeBausch
Posts: 9
Joined: 11 Sep 2013, 14:05

another USB stick unreadable

#1 Post by JoeBausch » 23 Sep 2013, 12:43

Yes, I have a 2nd USB flash drive that is unreadable. The first is in the thread "rehabbing a flash drive" that is still unresolved, but I want to start this new thread on this different unreadable stick drive.

(and I've corrected poor form on my part by contributing to Mr. Grenier's donation fund for the past and current help. :) )

Ok, this flash drive is 8 GB in size and is FAT32 (I used it get data from a library microfilm scanner on a PC over to me in the OS X world). Recently it became unreadable on my Mac. Note, I've run PhotoRec on this drive and it recovered many files, which is great, but without the file names I had given them they will be exceedingly difficult to use.

So I run at the command line with sudo the testdisk program. It defaults to a Mac partition, which I know it isn't since it is one of these generic flash drives of FAT32, so I switch the partition table type to Intel, then run Analyze. It says:

Partition sector doesn't have the endmark 0xAA55.

I ran Analyze and did a Quick Search and the response was:

Disk /dev/rdisk6 - 8086 MB / 7712 MiB - 15794176 sectors

Partition Start End Size in sectors


No partition found or selected for recovery


As I sat and thought about running a Deeper Search, I started reading older threads on the site and saw this one labeled "USB stick unreadable":

http://forum.cgsecurity.org/phpBB3/usb- ... -t462.html

It sounded pretty similar to my situation and forum member Fiona suggested the following to that user, the first line meaning to choose None as the partition:

Just keep this as None.
But don't confirm at Analyse but Advanced.
Check Type and press enter.
Check your previous file system (I've no idea either, has it been FAT32 or NTFS?).
Normally thumb drives are preformatted using FAT32.
So I assume FAT32?
Check FAT32 and press enter to continue.
Check Boot and press enter.
Check rebuild BS and press enter.
If it was succsesful you see a menu List.
Check it and press enter.
Do you see your data or an error message?


So I've started to follow Fiona's lead, and when I check Boot and press enter, the message from testdisk is this:

Disk /dev/rdisk6 - 8086 MB / 7712 MiB - 15794176 sectors
Partition Start End Size in sectors
P FAT32 0 15794175 15794176

Boot sector
Bad

Backup boot sector
Bad

First sectors (Boot code and partition information) are not identical.
Second sectors (cluster information) are not identical.
Third sectors (Second part of boot code) are not identical.

A valid FAT Boot sector must be present in order to access
any data; even if the partition is not bootable.


So I proceed with rebuild BS and after a few minutes of chugging along, the message back from testdisk is:

P FAT32 0 15794175 15794176
Cluster 114, Directory / found ?
Answer Y(es), N(o), Q(uit) or A(bort interactive mode). N or A if not sure.

>drwxr-xr-x 0 0 0 10-Sep-2013 05:19 .Spotlight-V100


I choose to Abort interactive mode and am letting it chug along for many more hours and using the Console program I am watching the testdisk.log file and I'm encouraged as I'm seeing some directories shown containing files with names I had gave them!

Finally that searching is done and the response from testdisk is:

Disk /dev/rdisk6 - 8086 MB / 7712 MiB - 15794176 sectors
Partition Start End Size in sectors
P FAT32 0 15794175 15794176

FAT : 32
cluster_size 8 136
reserved 32 34954
sectors 0 34952
total_sect 15794176 877237134
fat32_length 15396 3867043064
root_cluster 0 3914224481
free_count uninitialised 1583109
next_free uninitialised 29954
Extrapolated boot sector and current boot sector are different.
Warning: Extrapolated boot sector have incorrect values.



[ Dump ] >[ List ] [ Write ] [ Quit ]


When I hit List, I get this:

No file found, filesystem may be damaged.

And I'm not certain what to do next. Or whether I've taken a road that wasn't informative.

Any advice is appreciated.

Sponsored links

JoeBausch
Posts: 9
Joined: 11 Sep 2013, 14:05

Re: another USB stick unreadable

#2 Post by JoeBausch » 27 Sep 2013, 13:09

I went ahead and continued and did the choice of Write, but after a few minutes I received the following message from TestDisk:

Write error: Can't write new FAT boot sector

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests