64 GB USB with Corrupted exFAT

Using TestDisk to repair the filesystem
Forum rules
When asking for technical support:
- Search for posts on the same topic before posting a new question.
- Give clear, specific information in the title of your post.
- Include as many details as you can, MOST POSTS WILL GET ONLY ONE OR TWO ANSWERS.
- Post a follow up with a "Thank you" or "This worked!"
- When you learn something, use that knowledge to HELP ANOTHER USER LATER.
Before posting, please read https://www.cgsecurity.org/testdisk.pdf
Posts: 1
Joined: 23 Oct 2013, 07:37

64 GB USB with Corrupted exFAT

#1 Post by Fatih »

Hello Everyone

I have 64 GB USB with exFat file system and 4096 byte allocation unit size. I have connected it to an Android based bus entertainment system while I was on a trip. It didn't saw my USB and when I get home, my computer cannot read it. it says this drive needs a format to be able to being read.

I have found TestDisk and tried to use it to save my files. Unfortunately, I don't have much information about the software and all I did was to search the USB for partitions. Both "Quick Search" and "Advanced Search" did not found any partitions

I have selected Intel partition table type according to the hint given by the software.

Before searching the USB, this was the readable partition by TestDisk:
The Screenshot of TestDisk after clicking "Analyze" option in main menu.
The Screenshot of TestDisk after clicking "Analyze" option in main menu.
Adsız.jpg (70.65 KiB) Viewed 2070 times
Is it possible for me to recover my files? or because exFat is very closed and unknown file system or the current damage to the file system is beyond repair or recovery, it is not possible?

I am sorry if there were a beginners guide or manual that I should have read but didn't.

I would be very happy for any help you can give me. If you want any more information, feel free to ask.

Thanks very much